License text formatting is messed up

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
14 years ago
12 years ago

People

(Reporter: simon.andrews, Assigned: mostafah)

Tracking

Details

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.8

When running the Windows installer the formatting of the license text is messed
up.  It looks like a unix line ending problem as lines are not broken, but
contain characters which look like || where the breaks should be.

Reproducible: Always
Steps to Reproduce:
1.Start Sunbird installation on Windows
2.Read the license text.
3.
Actual Results:  
License text formatting was messed up.

Expected Results:  
Formatted the license correctly.

Comment 1

14 years ago
*** Bug 256227 has been marked as a duplicate of this bug. ***

Comment 2

14 years ago
Mostafah, can you look into this? I remeber seeing something like that on
Firefox during March. IIRC the Cygwin installation on Beast was a little bit
broken there.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 3

14 years ago
*** Bug 281261 has been marked as a duplicate of this bug. ***

Comment 4

14 years ago
Created attachment 173742 [details]
Screenshot of the text appearance on Windows XP

This bug still exists after 6 months.  Hopefully a visual reference will help
someone determine where the problem is.

Comment 5

14 years ago
Indeed back with Firefox it was a line break problem. I can have a look at this
tonight?

Comment 6

14 years ago
i'm new to sundbird, using LXR on seamonkey i find a series of licence files.
http://lxr.mozilla.org/seamonkey/search?string=%22commercial+use%22

which one goes into the sunbird installer?

Comment 7

14 years ago
*** Bug 296984 has been marked as a duplicate of this bug. ***

Comment 8

13 years ago
The new lines are not displayed correctly.

Comment 9

13 years ago
*** Bug 310073 has been marked as a duplicate of this bug. ***

Updated

13 years ago
QA Contact: installer
Created attachment 216909 [details]
Screenshot of Sb 0.3a1 installer on Windows Server 2003

As shown in the screenshot, I don't see the issue on the license file anymore.

It looks to me as if we use Firefox's LICENSE (NOT their EULA) when we build the installer. Perhaps that should change in the future.

http://lxr.mozilla.org/seamonkey/source/calendar/installer/windows/installer.cfg
Resolving WFM. 
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
Mass move of all Installer bugs to General per ctalbert.
Component: Installer → General
The bugspam monkeys have been set free and are feeding on Calendar :: General. Be afraid for your sanity!
QA Contact: installer → general
You need to log in before you can comment on or make changes to this bug.