onChange event fires "late" when using keyboard navigation

RESOLVED DUPLICATE of bug 126379

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 126379
13 years ago
13 years ago

People

(Reporter: Nicholas, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3

If you create a webpage with a SELECT element, and attach an onChange event to
that SELECT, it will fire when the user pulls the dropdown down and selects an
item. If you tab into the element with your keyboard, and hit the up and down
arrows to change the selection, the onChange element does not fire after each
change. It instead fires after you tab away from the element.

Reproducible: Always
Steps to Reproduce:



Expected Results:  
This is a different behavior than I expected, as selecting a different dropdown
item with the mouse triggers the onChange event, so why should a keyboard be any
different in regards to changing dropdown options?

Internet Explorer already seems to do it the way I envision-- firing onChange
even when it's changed by keyboard, and right after the item is changed, not
after the element loses focus.
(Reporter)

Comment 1

13 years ago
(In reply to comment #0)
> arrows to change the selection, the onChange element does not fire after each

I meant to say "the onChange _event_ does not fire after each".

Comment 2

13 years ago

*** This bug has been marked as a duplicate of 126379 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

13 years ago
(In reply to comment #2)
> 
> *** This bug has been marked as a duplicate of 126379 ***

José,

Sorry about the dupe. I could not find the other one using the search system.
Guess I need to polish up on my searching abilities.. thanks!
You need to log in before you can comment on or make changes to this bug.