Problems opening/switching popup windows in Mozilla and Firefox on MAC--Camino works fine, Safari Fine

RESOLVED WORKSFORME

Status

()

--
minor
RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: randy_towry, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7b) Gecko/20040316

I have a application which uses popups to process data. One receives a a form,
then writes back to the main screen using javascript instead of refreshing the
screen. Upon opening the window, the browser window becomes unfocused.

When I try to focus, and start typeing, I find myself in the select as you type.
I cannot enter text into a form unless I completely start over firefox/mozilla.
Note Camino works fine. On Windows, Firefox and Mozilla work great.
This is a coldfusion application which has a very large opener window, with a
form for every item (200 + possible).



Reproducible: Always
Steps to Reproduce:
1. The opener page script function createTarget(t)
{
quicknotewindow=window.open(' ', t, 'height=400,width=400,resizable=yes');
quicknotewindow.focus();
window.focus();
return true;
}


2. The opener form action
<form  id="form#attributes.bookmark#" name="form#attributes.bookmark#"
method="post"  action="judgeviewadversaryquicknotepopup.cfm" onsubmit="return
createTarget(this.target)" target="QUICKNOTE" >



3. The return/refocus on popup window

<SCRIPT LANGUAGE="JavaScript"><!--
	window.opener.focus();
	window.opener.document.getElementById('form<cfoutput>#form.bookmark#</cfoutput>').reset();

	window.opener.document.getElementById('note<cfoutput>#form.bookmark#</cfoutput>').value
= '<cfoutput>#variables.note#</cfoutput>';
	window.opener.document.getElementById('quicknote<cfoutput>#variables.nextfield#</cfoutput>').focus();
	setTimeout('window.opener.window.scrollByLines(5)',50);
	window.opener.document.getElementById('quicknote<cfoutput>#variables.nextfield#</cfoutput>').focus();
	<!--- self.close(); --->
		//--></SCRIPT>



Actual Results:  
Focus confusion

Expected Results:  
Open popups, focused on opener, written text

It seems to be related to other window.open problems in the Mac OS X.

My workaround is to use Camino for the Macintosh users.
(Reporter)

Updated

14 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
(Reporter)

Comment 1

14 years ago
9-1-2004

While looking at my javascript code, I am setting focus to two windows 
concurrently. Changing my code to focus on the opener after executing the popup 
took care of the issue.

Sorry...

Comment 2

14 years ago
Nothing in the Mozilla code was broken or fixed.

->WORKSFORME
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Updated

14 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.