Closed Bug 256174 Opened 16 years ago Closed 15 years ago

HR tag is rendered too large when SIZE specified as a decimal (less than 1.0)

Categories

(Core :: Layout, defect, minor)

defect
Not set
minor

Tracking

()

RESOLVED DUPLICATE of bug 52019

People

(Reporter: subscribe, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.1) Gecko/20040707
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.1) Gecko/20040707

This has to do with the way Mozilla handles an improperly-written HR tag.
Technically, the page in question should be fixed, but the way Mozilla handles
the bug is a bug itself.  (This may be a "quirks mode" issue?)

According to the HTML spec, the size of an HR tag should be specified in pixels.
However, if an HR tag is improperly specified as a decimal less than one (as
though one could have a horizontal rule a half-pixel in size), Mozilla ignores
the decimal point.  Example: <hr size=.500>

Reproducible: Always
Steps to Reproduce:
1. Create a new HTML file
2. Type this code: <hr size=.500>
3. Save
4. View the results in the browser

Actual Results:  
The HR tag was rendered incorrectly.

Expected Results:  
Mozilla should treat fractional HR tags as though they had a height of zero (or
one).  This would, at least, make the page functional until the author of the
page could be convinced to fix the problem.

I discovered this bug at http://www.domainnamesystems.com, but it happens
everywhere.
This is basically bug 52019
Depends on: 52019
Assignee: roc → nobody
Severity: normal → minor
Component: Layout: View Rendering → Layout
OS: Windows XP → All
QA Contact: ian → core.layout
Hardware: PC → All
As indicated in Comment #1, this is basically a duplicate of bug 52019. 
Resolving as DUPLICATE.

*** This bug has been marked as a duplicate of 52019 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.