Need UI to select calendars to be "locally shared"

RESOLVED WONTFIX

Status

--
enhancement
RESOLVED WONTFIX
14 years ago
4 years ago

People

(Reporter: ross, Unassigned)

Tracking

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3

I installed calendar to firefox 0.9.3 and thunderbird 0.7.3. Placing events on
calendar in thunderbird or firefox, they do not show up on the calendar in the
other application. Additionally, there does not appear to be any way to
configure (through the interface) where "calendar" stores its data, and thus no
way to allow  the thunderbird and the firefox calendar to share their data,
short of configuring them both to utilize a remote calendar store. I have not
tested that yet, but that seems overly complex to enable something as simple as
utilizing the same calendar locally between two copies of calendar.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 256179 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

14 years ago
This bug is not a duplicate of 256179. This is a feature request, 25179 was an
installer bug
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 4

14 years ago
Confirm, and fix summary to reflect the real desire of this bug

We need a UI and implementation to allow calendars to be "Locally Shared" as in
if we choose "Locally Share" [x] Calendar, then on a new install, (or perhaps
through other ways as well) we can see that there are locally shared calendar
files, and allow the user to import that file as a locally shared...

This would negate the need for that FAQ, and provice a much nicer way to do this
between multiple calendar installs (Sunbird, TB, FF, Suite)

I would suggest store this in a "Sunbird" directory under %APPDATA%, (if its not
too hard)...such that we can place a "shared" directory in there, and know where
to look
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: If I install calendar to firefox and to thunderbird, I would like the ability for them to share the same calendar data → Need UI to select calendars to be "locally shared"
If we want to promote shared calendars, we need to make real sure it works. And
currently, it doesn't. If you would use two programs at the same time, problems
arise. We need good locking.

Comment 6

14 years ago
I would not suggest adding this without (much) better locking support, and I
would have expected that to be implied, but thank you for mentioning it mvl.

Comment 7

14 years ago
A calendar setup like below works quite well in a five seat environment: its a
local calender (on the LAN network volume F:) defined as a remote (file://) so
it refreshes every time the calendar window is opened (a strictly local calendar
would only refresh, when the application was restarted), or on "refresh remote
calendars". to work around the absence of locking, each person has her own file,
and is only allowd to make changes to that one: added bonus is color coding. the
rdf was written in notepad. there is only one truly shared calendar for the
holidays, where the odds are 1:never against edits that overlap in time.

  <RDF:Description RDF:about="urn:calendarcontainer:calendar1"
                   NC:active="true"
                   NC:serverNumber="1"
                   NC:path="F:\Shared\Calendar\urlaub.ics"
                   NC:remote="true"
                   NC:username=""
                   NC:password=""
                   NC:name="Urlaub"
                   NC:remotePath="file://F:\Shared\Calendar\urlaub.ics"
                   NC:publishAutomatically="true"
                   NC:color="#CCFFFF" />

I consider it impossible to make a shared calendar safe without throwing in a
server/arbiter to eg. sequence concurrent change requests by different clients -
though I am not an educated computer scientist;)

Comment 8

14 years ago
*** Bug 235023 has been marked as a duplicate of this bug. ***

Comment 9

14 years ago
*** Bug 279653 has been marked as a duplicate of this bug. ***

Updated

13 years ago
QA Contact: gurganbl → general
*** Bug 306817 has been marked as a duplicate of this bug. ***
Reassigning all automatically assigned bugs from Mostafa to nobody@m.o

Bugspam filter: TorontoMostafaMove
Assignee: mostafah → nobody

Comment 12

13 years ago
You'd think this would be doable now that the "Lightning" thing has been worked on for a little while...
(In reply to comment #12)
> You'd think this would be doable now that the "Lightning" thing has been worked
> on for a little while...

Firefox and Thunderbird do not share each other's user profile directories. Lightning stores the calendar data inside the user's Thunderbird profile.

While valid input on bugs is appreciated, please refrain from adding "one-liner" comments that are of questionable value to the bug. For more information, see the Bugzilla Etiquette guide at https://bugzilla.mozilla.org/page.cgi?id=etiquette.html

Such comments simply waste developer time; time which would be better spent fixing bugs and improving the products.
(Reporter)

Comment 14

13 years ago
In this case, I'd note that I think this is fairly valid criticism. This bug is 2 years old, and it's fairly ridiculous that while Thunderbird & Firefox are sister products, the setup for having a calendar shared between the two applications is complex to the point that a non-technical person will likely never figure it out. 

Comment 15

13 years ago
(In reply to comment #14)
> In this case, I'd note that I think this is fairly valid criticism. This bug is
> 2 years old, and it's fairly ridiculous that while Thunderbird & Firefox are
> sister products, the setup for having a calendar shared between the two
> applications is complex to the point that a non-technical person will likely
> never figure it out. 
> 

This is a good reason to hurry up Bugzilla Bug 313822
Make lightning work on SeaMonkey.
I think we can WONTFIX this one as we don't support Firefox. If calendars should be shared between Seamonkey and Thunderbird for some strange reason, I think remote calendars are a viable option.
Status: NEW → RESOLVED
Last Resolved: 14 years ago4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.