Closed Bug 256196 Opened 20 years ago Closed 20 years ago

SubTODO/Hierarchal ToDo Request

Categories

(Calendar :: General, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 194863

People

(Reporter: coderarlo, Assigned: mostafah)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2

A hierachal todo system is important to users who like to keep large organized
lists of todos.  (Such as myself)
A system similar to Korganizer would be a good starting point, but eventually
enhancements to the Korganizer scheme could be made, such as:

* Setting the Percentage Complete of a TODO based on the Sub-Todos.
* Inheriting the Category of the Parent TODO (Setable Option)
* Children Summary.  Something like a table that pops up on mouse-over, showing
the Sub-Todos and their priority and due date.
* Indicators for Due Children.  (Display a small Icon next to the parent if it
contains a child that is past its start date and a different icon for a child
past its due date.)

Good Job on the Calendar system so far.  I've been impressed by the mozilla
developer's taste in their interfaces.  Little things such as makeing the TODO
change color when past its start date add a lot to the application.  I've been
tired of the meaningless start date in other PIMs.  Hopefully SunBird will
become a success along with firefox and thunderbird.

Reproducible: Always
Steps to Reproduce:
Duplivate of 194863

*** This bug has been marked as a duplicate of 194863 ***
Status: UNCONFIRMED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
The bugspam monkeys have been set free and are feeding on Calendar :: General. Be afraid for your sanity!
QA Contact: gurganbl → general
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.