Firefox crash when deleting profile from non-standard location

RESOLVED DUPLICATE of bug 245053

Status

()

Toolkit
Startup and Profile System
--
critical
RESOLVED DUPLICATE of bug 245053
14 years ago
10 years ago

People

(Reporter: WD, Assigned: Benjamin Smedberg)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3

I have been running Firefox for a while, so my profile location isn't currently
the standard location (I believe).  It's in C:\Documents and
Settings\<username>\Application Data\Firefox

C:\Documents and Settings\<username>\Application Data\Mozilla\Firefox contains a
profiles.ini file that points to the above location where the profile really is.

I can create profiles, and that works fine, but when I try to delete them and it
asks me if I want to delete the files, Firefox crashes when I click Yes.

Reproducible: Always
Steps to Reproduce:
1.Create a new profile
2.Delete the profile
3.

Actual Results:  
Firefox crashes

Expected Results:  
No crash

The crash gives the error:

The instruction at "0x00406a37" referenced memory at "0x0000001c". The memory
could not be "written".
(Reporter)

Comment 1

14 years ago
Created attachment 156558 [details]
My profiles.ini file

Note: The profile directories *are* deleted when I tell Firefox to, but
immediately following that Firefox crashes.   The entries in profiles.ini are
never removed.	(So they remain in the profile manager, though the files for
the profiles are gone)

Comment 2

14 years ago
Fix will be included with release versions from 1.0 Preview Release on.

*** This bug has been marked as a duplicate of 245053 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.