If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[FEATURE] Drop-down URL list (history) below URL bar

VERIFIED FIXED in M17

Status

SeaMonkey
UI Design
P2
normal
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: Jason Eager, Assigned: Radha on family leave (not reading bugmail))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
This is probably a dup, but I can't find it in
bugzilla anywhere and it isn't marked under M14...

I assume that that arrow pointing downwards left of the
blue "Search" word and arrow will eventually trigger a
drop down list of the last 10 or so urls manually entered
into the bar, just like NS 4.x.

That feature is pretty much dogfood for me, and I was wondering
who was planning to impliment it, what implimenting the drop down
list depended on, and if there was anything that I could do to speed
up the process significantly. (such as implimenting it myself).
(Reporter)

Comment 1

18 years ago
If no-one is planning on implimenting this anytime soon or in a different manner
then I'm planning to do it, this enhancement depends on the implimentation
of the nsIManualHistory component.
Depends on: 25735

Comment 2

18 years ago
German, has we actually planned to do this in 5.0?  (Re-assign back to me if
yes.)
Assignee: don → german

Comment 3

18 years ago
Yep that is planned for 5.0. Not sure about the timing, but the current plan is 

that the dropdown conatins a combination of popular keywords as well as the 10 

most recently input (and successfully executed) strings for any of the windows. 

Note that this is different than the 10 most recently visited URLs which will be 

accessible from the extended back button as well as the GO menu. Re-assigning to 

Don for implementation thorugh his team and determining timeline

Assignee: german → don

Comment 4

18 years ago
Moving this out to M16 for Radha ...
Assignee: don → radha
Severity: enhancement → normal
Priority: P3 → P2
Summary: [RFE] Impliment drop-down url list below url bar. → [FEATURE] Drop-down URL list below URL bar
Target Milestone: M16
(Reporter)

Comment 5

18 years ago
So how much of a back-end have you implimented for this yet?

Should I go ahead with 25735 (I'm already deep into the design of it), or
would that be a massive duplication of effort?

Status: NEW → ASSIGNED
*** Bug 30402 has been marked as a duplicate of this bug. ***
Target Milestone: M16 → M17
No work on the backend has been done. Please see my comments in 25735.

Updated

18 years ago
QA Contact: paulmac → claudius
*** Bug 34846 has been marked as a duplicate of this bug. ***

Comment 9

18 years ago
*** Bug 34876 has been marked as a duplicate of this bug. ***

Comment 10

18 years ago
*** Bug 34965 has been marked as a duplicate of this bug. ***

Comment 11

18 years ago
*** Bug 32747 has been marked as a duplicate of this bug. ***

Comment 12

18 years ago
*** Bug 34775 has been marked as a duplicate of this bug. ***

Comment 13

18 years ago
*** Bug 37916 has been marked as a duplicate of this bug. ***

Comment 14

18 years ago
> 10 most recently input (and successfully executed) strings

The "successfully executed" requirement in 4.x is sometimes very annoying. IIRC,
one
case was, when the server redirected the URL and I wanted to try a slightly
different one.
Summary: [FEATURE] Drop-down URL list below URL bar → [FEATURE] Drop-down URL list (history) below URL bar

Comment 15

18 years ago
> the current plan is that the dropdown conatins a combination of popular
> keywords

See bug 37873.

Updated

18 years ago
Keywords: nsbeta2
Feature checked in last night.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 17

18 years ago
vrfy fixed 2000051208 linux, win98, win2k
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.