Closed Bug 256237 Opened 16 years ago Closed 16 years ago

Folder Properties dialog can't use Ctrl+Tab switch to first tab from the last

Categories

(SeaMonkey :: MailNews: Message Display, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 130644

People

(Reporter: ginnchen+exoracle, Assigned: sspitzer)

Details

1) Mailnews->Menu->Edit->Fold Properties

2) Now it's in "General Information" Tab, press ctrl+tab, it will focus "Name"
field [another bug]

3) Press ctrl+tab 3 times, it switches to "Offline", "Sharing", "Quato" tabs.

4) Press ctrl+tab again, nothing happens.
Note that only IMAP folders have multiple tabs on their Properties dialog.

In Moz1.7 and TB0.7, it appears that if the focus is on an item in the property 
sheet, Ctrl-Tab/Ctrl-Shift-Tab will move between tabs; but if the focus is on 
the Ok or Cancel button, focus will move to the first control on the displayed 
sheet.  However, if the sheet does not have any focusable items, the focus falls 
off of the sheet onto the Ok button.

In bug 166001 comment 2, Aaron Leventhal states:
> The part of this where ctrl+tab gets stuck on a pane with no focusable
> content is bug 130644.

Bug 130644 is marked fixed due to patch for bug 175893, also Aaron's work (just 
in the past month).  Using Moz 1.8a3-0806, this problem does not manifest, altho 
the solution is a little clunky: Shifting to a page without an item still lets 
the focus drop to the OK; then the first Ctrl-Tab puts the focus on the tab 
control, but does not shift to the next page; a second Ctrl-Tab properly moves 
to the next page, but maintains the focus on the tabs rather than moving to a 
control in the page.

Ginn Chen, I am presuming that you filed this bug with a 1.7 build or earlier, 
but you neglected to provide a build ID.  Duping.

*** This bug has been marked as a duplicate of 130644 ***
Status: NEW → RESOLVED
Closed: 16 years ago
OS: Linux → All
Hardware: PC → All
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.