Strings not get selected in their entirety upon a double-click

RESOLVED WONTFIX

Status

()

Core
Selection
RESOLVED WONTFIX
13 years ago
13 years ago

People

(Reporter: Anupama, Unassigned)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.1) Gecko/20040707
Build Identifier: Mozilla1.8a2

Strings not get selected in their entirety upon a double-click 

Reproducible: Always
Steps to Reproduce:
Item # 7 
 Double-click  on strings given below :
Rogers'
won't
35.52%
$50
$25.50

Actual Results:  
Strings are partially get selected upon double-click.


Expected Results:  
All Strings should be selected in their entirety upon a double-click
double-click selects a single word.  Words are separated by punctuation
(characters like apostrophes, periods, dollar signs, etc).
Summary: Strings not get selected in their entirety upon a double-click → Strings not get selected in their entirety upon a double-click

Comment 2

13 years ago
This is set by a preference.  Windows developers wanted it to stop at
punctuation, so that's the default.  If you want to change that, create a
user.js (if you don't already have one) in your profile directory (wherever
prefs.js lives now), and put this in it:
user_pref("layout.word_select.stop_at_punctuation", false);
Or just change the value of that pref in about:config (that will change it in
the current session).

Closing the bug as wontfix, since it's intentional.  If you think this is the
wrong default behavior for Windows, reopen it (and it will need to go to a
windows ue person for discussion).

Funny how that testcase doesn't specify anything about platform, so it's wrong
for everything except Windows.  That page claims to be owned by Terri Preston
with an @netscape.com address.  I wonder if that's a current address?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.