More flexibility needed in managing cookies

RESOLVED WONTFIX

Status

()

--
enhancement
RESOLVED WONTFIX
14 years ago
14 years ago

People

(Reporter: green_innovatns, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3

Dear Firefox designers,

I've got a suggestion for more user friendly handling of cookies.

At the moment if you get Firefox to ask what to do with cookies on a case by
case basis you get four options:

........Show details

........Allow

........Allow for session

........Deny

........Use my choice for all coookies on from this site


I think it would be extemely useful to have an option for:

"Deny for session"

This is because some URLs set lots of cookies or keep on triggering the ask
function masssive numbers of times. The only way currently to stop this is to
deny the setting of cookies permanently. But you might not want to do that if
after some browsing you need to accept cookies, for example, to allow passwords
to be recorded or to enable financial transactions etc.

In addition I think there should be a toobar button/menu option for modifying
the current remembered cookie setting for the current particular URL. This
avoids the considerable inconvenience of making these changes through the cookie
management option

"Deny" could be changed to:

........Ask

........Ask for session

........Allow

........Allow for session

"Deny for session" could be changed to:

........Deny

........Ask

........Ask for session

........Allow

........Allow for session


"Allow" could be changed to:

........Ask

........Ask for session

........Deny

........Deny for session


"Allow for session" could be changed to:

........Ask

........Ask for session

........Deny

........Deny for session

The dialogue box for this should indicate what the current status is for coookie
management so you can be sure what you are changing from.


Cheers, Philip
_________________
Philip Sutton
http://www.green-innovations.asn.au/
Philip.Sutton@green-innovations.asn.au

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Updated

14 years ago
Component: Web Site → General
You're talking about something that involves changing what some of the text
really means.  Allow for Session isn't for the site, unless you make it that
way.  It allows that _cookie_ to be set but with an expiry at the end of the
session.  Deny for Session would not be any different from Deny, unless we
change the meaning of Allow for Session, which we're not going to do.

Since that's the gist of this bug, marking WONTFIX, since the backend does not
and probably will not support something like this.

The site-specific settings UI should be in 1.8, but it will be more than just
cookies.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.