Closed Bug 256285 Opened 18 years ago Closed 15 years ago

Return receipts should be more flexible

Categories

(SeaMonkey :: MailNews: Backend, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 151244

People

(Reporter: johnhoogstrate, Assigned: Bienvenu)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040514
Build Identifier: 

When the sender of an e-mail has set a Return receipt the receiver is prompted
with a window to confirm that the e-mail has been read at the moment the e-mail
is selected.

How is it possible to confirm that you read an e-mail before you were able to
read it?

If you click "no" there is no way you can send a return receipt on a later moment.

If you click "yes" an e-mail is sent directly. However, this e-mail is not
displayed in the "Sent" folder. The user has no control over the message that
has been sent.

Here's what I think what would make the whole return receipt a lot less annoying:

- The return receipt prompt should appear after the e-mail has been read, or
better: when a button is clicked in the "info bar" (where e-mail info and the
list attachments is displayed)
- The ability to sent a receipt on a later date, even after cancelling it the
first time.
- See which e-mail want's a receipt in the list view by giving it an alternate icon.
- Mark e-mail for which a return receipt has been sent.
- Returned receipt in the Sent folder.
- The ability to set a standard return receipt text for each account.

Reproducible: Always
Steps to Reproduce:
1. Compose an e-mail
2. fill in your own address
3. Check "Return Reciepnt" from the "Options" menu.
4. Send the email
5. Check your email
Product: Browser → Seamonkey
Seems related to bug 151244?
AFAICS, yes; this is a duplicate of bug 151244.
Interesting recommendations by Johnny should be crossposted to the comments of that one.
(In reply to comment #2)
> Interesting recommendations by Johnny should be crossposted to the comments
> of that one.

I don't think all of his recommendations are duped by that bug, and shouldn't necessarily be copied over.

(In reply to comment #0)
> - The return receipt prompt should appear after the e-mail has been read, or
> better: when a button is clicked in the "info bar" (where e-mail info and the
> list attachments is displayed)

Bug 151244.

> - The ability to sent a receipt on a later date, even after cancelling it the
> first time.

Also bug 151244.

> - See which e-mail wants a receipt in the list view by giving it an alternate
>   icon.
> - Mark e-mail for which a return receipt has been sent.

Bug 336223.


> - Returned receipt in the Sent folder.

I'm not sure this is a good idea; user can set up a filter for this.


> - The ability to set a standard return receipt text for each account.

The text is determined per the RFC on MDN, no?
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 151244
(In reply to comment #3)
> > - Returned receipt in the Sent folder.
> 
> I'm not sure this is a good idea; user can set up a filter for this.

duh -- this is actually an existing option.
Component: MailNews: Return Receipts → MailNews: Backend
QA Contact: grylchan → offline
You need to log in before you can comment on or make changes to this bug.