If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

crash if i open gmail notifier and bloglines notifier in separate tabs [@ JS_HashTableRawAdd ]

RESOLVED DUPLICATE of bug 256827

Status

()

Firefox
General
--
critical
RESOLVED DUPLICATE of bug 256827
13 years ago
6 years ago

People

(Reporter: Maurice, Assigned: Blake Ross)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2

I am currently running Firefox 0.9.2 with Gmail Notifier v0.3.3 and Bloglines
Notifier v1.4. When starting the browser, I click on the Gmail Notifier and
Bloglines Notifier icons in the status bar. However, once both load in new tabs,
the browser crashes. However, once I re-start the browser and repeat the same
action, it doesn't crash.

Reproducible: Always
Steps to Reproduce:
1. Install Bloglines Notifier v1.4 and Gmail notifier v0.3.3.
2. Close your browser after installing each, then re-open.
3. Click both the icons when they have new items.

Actual Results:  
The browser crashes every time. However, once I re-start the browser and repeat
the same action, it doesn't crash.

Expected Results:  
Loaded both tabs and not crashed.

I have several Talkback crash ID's. The most recent one is TB616235Y.

Comment 1

13 years ago
TB616235Y:
JS_HashTableRawAdd 
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/js/src/jshash.c,
line 233]
js_AtomizeHashedKey 
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/js/src/jsatom.c,
line 491]
js_AtomizeObject 
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/js/src/jsatom.c,
line 516]
FunctionStmt 
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/js/src/jsparse.c,
line 965]
Statements 
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/js/src/jsparse.c,
line 997]
js_CompileTokenStream 
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/js/src/jsparse.c,
line 451]
CompileTokenStream 
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/js/src/jsapi.c,
line 3020]
JS_CompileUCScriptForPrincipals 
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/js/src/jsapi.c,
line 3101]
JS_EvaluateUCScriptForPrincipals 
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/js/src/jsapi.c,
line 3555]
nsJSContext::EvaluateString 
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/dom/src/base/nsJSEnvironment.cpp,
line 946]
nsScriptLoader::EvaluateScript 
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/content/base/src/nsScriptLoader.cpp,
line 660]
nsScriptLoader::ProcessRequest 
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/content/base/src/nsScriptLoader.cpp,
line 573]
nsScriptLoader::ProcessScriptElement 
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/content/base/src/nsScriptLoader.cpp,
line 519]
nsHTMLScriptElement::MaybeProcessScript 
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/content/html/content/src/nsHTMLScriptElement.cpp,
line 656]
nsHTMLScriptElement::SetDocument 
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/content/html/content/src/nsHTMLScriptElement.cpp,
line 469]
HTMLContentSink::ProcessSCRIPTTag 
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/content/html/document/src/nsHTMLContentSink.cpp,
line 4340]
HTMLContentSink::AddLeaf 
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/content/html/document/src/nsHTMLContentSink.cpp,
line 3194]
HTMLContentSink::AddHeadContent 
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/content/html/document/src/nsHTMLContentSink.cpp,
line 3145]
CNavDTD::AddHeadLeaf 
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/htmlparser/src/CNavDTD.cpp,
line 3839]
CNavDTD::HandleStartToken 
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/htmlparser/src/CNavDTD.cpp,
line 1832]
CNavDTD::HandleToken 
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/htmlparser/src/CNavDTD.cpp,
line 1019]
CNavDTD::BuildModel 
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/htmlparser/src/CNavDTD.cpp,
line 511]
nsParser::BuildModel 
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/htmlparser/src/nsParser.cpp,
line 1899]
Severity: normal → critical
Keywords: crash
Summary: crash if i open gmail notifier and bloglines notifier in separate tabs → crash if i open gmail notifier and bloglines notifier in separate tabs [@ JS_HashTableRawAdd ]
Dupe based upon stack.

*** This bug has been marked as a duplicate of 256827 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Crash Signature: [@ JS_HashTableRawAdd ]
You need to log in before you can comment on or make changes to this bug.