location bar & form fields: CTRL-U doesnt work as it used to

VERIFIED FIXED in M15

Status

SeaMonkey
General
P3
normal
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: msuencks, Assigned: Akkana Peck)

Tracking

({pp})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: Fix in hand)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
in Netscape 3.x ,4.x CTRL-U deleted the content of the
field, now it only deletes content left of the cursor
which is rather useless IMHO.

but maybe this is GTK's fault

Comment 1

18 years ago
looks similar to bug 16015, except asking for different functionality than
what was implemented.

Comment 2

18 years ago
Moving all UE/UI bugs to new component: User Interface: Design Feedback
UE/UI component will be deleted.
Component: UE/UI → User Interface: Design Feedback

Comment 3

18 years ago
reassign to myself; cc akkana
Akkana--I have quite a few keybinding bugs.  If you want this particular one (or
if it's already fixed), please let me know!
Assignee: shuang → brade
(Assignee)

Comment 4

18 years ago
This is my fault -- I implemented it that way because I thought it was what it
was supposed to do.  You're right, it deletes the whole line in 4.x and in tcsh.

Kathy: we'll have to fix this in the editor controller's implementation, not in
the keybindings themselves.  I'll take the bug since it's my fault, but if you
have time and want to fix it, feel free to take it back.
Assignee: brade → akkana
(Assignee)

Comment 5

18 years ago
Marking M14, but since it's not marked beta1 it'll probably get bumped to M15.
Status: NEW → ASSIGNED
Target Milestone: M14
(Assignee)

Comment 6

18 years ago
Another thing that doesn't work right: ^K when on a blank line should delete the
line.

Comment 7

18 years ago
Based on comments in bug 16015, adding 4xp and pp keywords - this is Unix/Linux
only - so that it is clear.
Keywords: 4xp, pp
(Assignee)

Comment 8

18 years ago
Moving non-beta1 issue to M15.  I wish I was allowed to check in a fix sooner,
though!  (I really miss the correct ^K behavior.)
Target Milestone: M14 → M15
(Assignee)

Comment 9

18 years ago
I have an easy fix for both ^U and ^K.  Unfortunately I can't check it in until
M15, so I'm attaching a patch here lest I lose it between now and when the tree
opens.  (Anybody want to argue for beta1 status?)
Whiteboard: Fix in hand
(Assignee)

Comment 10

18 years ago
Created attachment 5915 [details] [diff] [review]
Patch to fix the problem
(Assignee)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 11

18 years ago
I've checked in a fix for ^U, and also made ^K behave more like users expect (if
positioned on a blank line, it will remove the line).

Comment 12

18 years ago
*** Bug 31498 has been marked as a duplicate of this bug. ***

Comment 13

18 years ago
Verified fixed on 3.29.00 Linux build; specifically, placing the caret in a text
field (whether URL or form) and pressing Control-U results in all text (whether
to the left or right of the caret) cleared.

Moreover, on Windows and Mac OS, placing the caret into a text field and
pressing Control-U has no effect whatsoever.
Status: RESOLVED → VERIFIED

Updated

15 years ago
Component: User Interface Design → Browser-General
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.