Closed Bug 256472 Opened 17 years ago Closed 17 years ago

Files downloaded with Firefox are not copyable to a different computer through a network

Categories

(Toolkit :: Downloads API, defect)

x86
Windows XP
defect
Not set
major

Tracking

()

VERIFIED DUPLICATE of bug 224692

People

(Reporter: mintcheerios, Assigned: bugs)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3

A file downloaded with Firefox 0.9.3 cannot be copied through to a different
computer through the network.  If attempted, the user will receive an error
along the lines of "Cannot copy (File that was downloaded by Firefox): Access is
denied. Make sure the disk is not full or write-protected and teh file is not
currently in use"

A temporary work around is to make another copy of the file and delete the old
one ot to just move the file from one place and back.

If the file was downloaded by Internet Explorer or some download manager, this
problem wouldn't occur.

Reproducible: Always
Steps to Reproduce:
1.Download a file with Firefox 0.9.3's download manager.
2.In Windows XP, try to copy that file over the network.

Actual Results:  
I received a read error.

Expected Results:  
It should have let the file copy through the network.
The flaw was/is still present in versions 1.0PR/1.0

Seems to happen only with a host running Windows XP Pro, not on XP Home
(different security polices?).
The following procedure *alway* give the same results.

I obtained it with the following:
1. A local network, with at least one XP Pro host, running FF
2. Change the default behaviour of FF to ask for a directory where to save
downloads (any other setting has influence)
3. The XP Pro host has one or more shared folders; other hosts on local network
(tried with Win 98SE, XP Pro, XP Home, Linux/Samba) are already able to read
files from that folder
4. Download/save a file from an http/ftp site on the XP Pro host, save it to a
local folder, shared on local network
5. File *can't* be accessed by other hosts on local network
6. Moving or copying the file to other directories, then back to the shared
folder, makes the file accessible from local network
Summary: Files downloaded with Firefox 0.9.3 are not copyable to a different computer through a network → Files downloaded with Firefox are not copyable to a different computer through a network
dupe of Bug 224692?
I have run into this problem.  I checked out the most recent build as required.
 The XP downloads always sets the ACL to a specific set of permissions rather
than inheriting the permissions of the directory.  Consequently the network
logins which are set up to get to the directory still can't get to the
downloaded file. The only exception I noticed was when the download goes to the
desktop; but I expect XP monkeys with this particular directory.

I am not looking at the source so I don't have any idea why; maybe an incomplete
use of the XP API.  I did check IE and it doesn't do this, so there must be some
rational resolution.  It causes me a problem only because I keep some
directories synced up and this access problem hoses my sync process.  

Unfortunately it can be rather confusing to someone using XP Home since they
can't actually get a look at the ACL.  At least I don't think they can.

*** This bug has been marked as a duplicate of 224692 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.