If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

overflow:auto elements cannot be scrolled with mouse wheel or keyboard

VERIFIED DUPLICATE of bug 97283

Status

SeaMonkey
General
VERIFIED DUPLICATE of bug 97283
13 years ago
13 years ago

People

(Reporter: Mitchell Mebane, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3

Elements with a CSS style of overflow: auto set and enough content to trigger a
scroll bar cannot be scrolled with the mouse wheel or keyboard wheel. They _can_
be scrolled with the scroll bar. Clicking in the element does not make a difference.

This is tested on WinXP Pro SP1 with Firefox 0.8 and 0.9 series.

I've found some bugs similar to this, bug I didn't see one describing this exact
problem. If this is a dupe, sorry.

Reproducible: Always
Steps to Reproduce:
1. Visit http://glide64.emuxhaven.net/ or http://mmxg.no-ip.com/about.php
OR
Create a page with an element styled overflow: auto, then fill the element with
a large amount of content
2. Make sure the browser window is smaller than the content and is causing
scroll bars to display
3. (optional) Click in the content area to insure focus
4. Attempt to scroll with the mouse wheel or keyboard arrows

Actual Results:  
Nothing

Expected Results:  
The element should scroll

I have Windows XP Pro w/ SP1 and a Logitech MX500 optical mouse. I do not have
the Logitech Mouseware drivers installed, but I don't think this affects the
problem, since it occurs with keyboard navigation as well.

Comment 1

13 years ago
worksforme with Mozilla Suite nightly winxp 2004080708 and logitech optical
mouse Logitech Pilot Wheel Mouse Optical M-BT96a

Comment 2

13 years ago
Same problem in Firefox 0.9.2.

Workaround: Hit the TAB-key to move focus to an element in the DIV (for example
an anchor). Now the scroll wheel works...
This is fixed in recent nightlies, see bug 97283.

*** This bug has been marked as a duplicate of 97283 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.