Closed Bug 256552 Opened 17 years ago Closed 17 years ago

Javascript events interfere with Tabbed Browsing

Categories

(Firefox :: Tabbed Browser, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 245502

People

(Reporter: kalyanbk, Assigned: bugs)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9

I have all my mail sites in a bookmark group and usually open them all
simultaneously in tabs. Some mail sites like hotmail have javascript that sets
the focus on the user name or password textbox after loading.

However if I am in a different tab and entering some data in a form, I find that
this setting focus on the hotmail tab takes away control from what I am typing
and what I type appears in the Hotmail tab textbox rather than in my current tab.

For example I am typing in my email address in a form in the current tab:

abc@xyz.com

Depending on when hotmail finishes loading and javascript sets focus,

Current tab Email field: abc@x
Hotmail Tab: yz.com

Reproducible: Always
Steps to Reproduce:
1. Have mail sites like Hotmail, Yahoo, Netscape, Gmail etc., in a bookmark group
2. Open them all simultaneously over a fast connection
3. Start entering data in a form in one of the tabs
4. When Hotmail finishes loading and javascript sets focus on the text box,
whatever you type in the current form no longer appears in the form
5. Switch to the Hotmail tab and you will see the text you typed.

This also happens with other sites that sets focus on a text box.
Actual Results:  
The text you type in a form in one tab appears in another tab due to javascript
set focus

Expected Results:  
Javascript events in one tab should not affect what I am doing in another tab.

*** This bug has been marked as a duplicate of 245502 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.