choice about install for "current user" or "all users"

RESOLVED WONTFIX

Status

()

--
enhancement
RESOLVED WONTFIX
14 years ago
8 years ago

People

(Reporter: moixa, Unassigned)

Tracking

unspecified
Future
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040707 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040707 Firefox/0.8

When installing as Administrator on a Windows machine, Firefox is installed for
all users (creating Desktop/Start Menu icons for all users).

This behaviour should be customisable. A
"Install for:
  [ ] Current User
  [x] All Users (need administrator rights)"
would do the job.

Installation goes to "Program Files" as usual, but icons and stuff goes to
user-profile-path instead of "Default User".

See also bug 28174 for Browser-product of Mozilla.

Reproducible: Always
Steps to Reproduce:
(Reporter)

Comment 1

14 years ago
See also bug 259394?

*** This bug has been marked as a duplicate of 245392 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
OS: Windows 2000 → Windows XP
Resolution: --- → DUPLICATE

Comment 3

14 years ago
I disagree that this dups to bug 245392.

What's documented here is a request for new functionality.  Bug 245392 is about
fixing the existing, broken functionality that already exists.  The patch
waiting review there is clearly not going to fix this bug (if it is decided to
address this bug's issue).
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
That bugs current patch is only addressing one minor problem, and isn't dealing
with the entire bug. The original intent of that bug, whether it's clear now or
not, was to redo the interface for choosing where to put the icons. It sort of
got derailed to also include the installer putting stuff where it shouldn't.

I resolved this as a dupe because when that UI is done, this will most likely be
incorporated. Anyways, depends is fine and is in fact probably better.

In short: you're right :).
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

14 years ago
Depends on: 245392

Comment 5

14 years ago
*** Bug 259394 has been marked as a duplicate of this bug. ***

Updated

13 years ago
Assignee: bugs → nobody
QA Contact: bugzilla → installer
No longer depends on: 245392

Updated

10 years ago
Target Milestone: --- → Future

Comment 6

10 years ago
3 (4) years later, this is still not resolved.

(just pinging, I mean there is nothing new to report)
Not going to implement this since the way Microsoft implemented browser integration requires setting some registry keys at the system level and providing this option would confuse users when they couldn't completely set as default due to the missing registry keys.
Status: NEW → RESOLVED
Last Resolved: 14 years ago8 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.