crash if I want to browse on the page [@ JS_malloc ][@ JS_ArenaAllocate ][@ js_atom_marker ]

RESOLVED DUPLICATE of bug 244470

Status

--
critical
RESOLVED DUPLICATE of bug 244470
14 years ago
8 years ago

People

(Reporter: jiri.holy, Unassigned)

Tracking

({crash, regression, testcase})

Trunk
x86
All
crash, regression, testcase

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

Attachments

(2 attachments, 2 obsolete attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a3) Gecko/20040817
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a3) Gecko/20040817

When I try to browse this URL
http://www.sparxsystems.com.au/EAUserGuide/exporttoxmi.htm mozilla crashes down.


Reproducible: Always
Steps to Reproduce:
1. Start mozilla.exe.
2. Paste URL http://www.sparxsystems.com.au/EAUserGuide/exporttoxmi.htm url edit
window.
3. Press enter.

Actual Results:  
Mozilla crashes down.
(Reporter)

Comment 1

14 years ago
Created attachment 156775 [details]
Quality Feedback Agent output

There is The Nescape Quality Feedbac Agent output.

Comment 2

14 years ago
can you post Talkback Incident ID associated to this crash
"mozilla\components\talkback.exe" ?
Keywords: crash, stackwanted

Comment 3

14 years ago
libc.so.6 + 0x759cc (0x4095f9cc)
libc.so.6 + 0x734bf (0x4095d4bf)
JS_malloc() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/js/src/jsapi.c,
line 1464]
js_NewObject() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/js/src/jsobj.c,
line 1835]
js_NewFunction() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/js/src/jsfun.c,
line 1884]
js_DefineFunction() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/js/src/jsfun.c,
line 1949]
JS_InitClass() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/js/src/jsapi.c,
line 1935]
js_InitArrayClass() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/js/src/jsarray.c,
line 1410]
JS_ResolveStandardClass() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/js/src/jsapi.c,
line 1390]
nsWindowSH::NewResolve() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/dom/src/base/nsDOMClassInfo.cpp,
line 4274]
XPC_WN_Helper_NewResolve() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp,
line 929]
js_LookupProperty() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/js/src/jsobj.c,
line 2430]
js_FindProperty() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/js/src/jsobj.c,
line 2542]
js_Interpret() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/js/src/jsinterp.c,
line 3434]
js_Execute() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/js/src/jsinterp.c,
line 1509]
JS_EvaluateUCScriptForPrincipals() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/js/src/jsapi.c,
line 3639]
nsJSContext::EvaluateString() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/dom/src/base/nsJSEnvironment.cpp,
line 141]
nsScriptLoader::EvaluateScript() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/content/base/src/nsScriptLoader.cpp,
line 672]
nsScriptLoader::ProcessRequest() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/content/base/src/nsScriptLoader.cpp,
line 587]
nsScriptLoader::OnStreamComplete() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/content/base/src/nsScriptLoader.cpp,
line 909]
nsStreamLoader::OnStopRequest() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/netwerk/base/src/nsStreamLoader.cpp,
line 606]
nsStreamListenerTee::OnStopRequest() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/netwerk/base/src/nsStreamListenerTee.cpp,
line 66]
nsHttpChannel::OnStopRequest() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/netwerk/protocol/http/src/nsHttpChannel.cpp,
line 947]
nsInputStreamPump::OnStateStop() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/netwerk/base/src/nsInputStreamPump.cpp,
line 947]
nsInputStreamPump::OnInputStreamReady() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/netwerk/base/src/nsInputStreamPump.cpp,
line 341]
nsInputStreamReadyEvent::EventHandler()
PL_HandleEvent() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/xpcom/threads/plevent.c,
line 693]
PL_ProcessPendingEvents() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/xpcom/threads/plevent.c,
line 627]
nsEventQueueImpl::ProcessPendingEvents() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/xpcom/threads/nsEventQueue.cpp,
line 395]
event_processor_callback() 
[/builds/tinderbox/firefox/Linux_2.4.20-28.8_Clobber/mozilla/widget/src/gtk2/nsAppShell.cpp,
line 67]
Keywords: stackwanted
OS: Windows 2000 → All
Summary: crash if I want to browse on the page → crash if I want to browse on the page [@ JS_malloc ][@ JS_ArenaAllocate ]

Comment 4

14 years ago
Created attachment 156785 [details]
Mozilla debug stack 20040604 Linux

Updated

14 years ago
Attachment #156775 - Attachment is obsolete: true
(Reporter)

Comment 5

14 years ago
Created attachment 156786 [details]
talkback screenshot

I have no incident in talkback.exe.
Option 'Turn Agent On' is checked in menu 'Settings'.

Comment 6

14 years ago
Comment on attachment 156786 [details]
talkback screenshot

Thanks, I got a crash and stacktrace on Linux anyway.
Attachment #156786 - Attachment is obsolete: true

Comment 7

14 years ago
WFM, Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040803
Firefox/0.9.3
Confirming bug, settings status to NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 9

14 years ago
Created attachment 156813 [details]
Testcase
Regression occured: 2004-04-12-07 -- 2004-04-13-08
There's a JS checkin that looks promising in that interval, for bug 169559 and
bug 165201.
Keywords: regression, testcase

Updated

14 years ago
Summary: crash if I want to browse on the page [@ JS_malloc ][@ JS_ArenaAllocate ] → crash if I want to browse on the page [@ JS_malloc ][@ JS_ArenaAllocate ][@ js_atom_marker ]

Comment 11

14 years ago
found this two weeks old Talkback:
TB634560X on Mozilla/Win98
http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=2&type=iid&id=TB634560X

URL currently working on
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8a3) Gecko/20040906
I no longer see this crash; anybody else?  Build 2004-11-13-05, Seamonkey trunk
on XP.
The testcase hangs 2004-11-13-06 trunk Linux, so the problem is still there...
Product: Browser → Seamonkey
The testcase nor the url crash for me, using 2005-01-22 trunk build.
The testcase looks rather similar to that of bug 244470. Maybe this bug is
related to that one?

*** This bug has been marked as a duplicate of 244470 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Crash Signature: [@ JS_malloc ] [@ JS_ArenaAllocate ] [@ js_atom_marker ]
You need to log in before you can comment on or make changes to this bug.