If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Absolutely positioned divs do not resize when list-style-images load

VERIFIED FIXED

Status

()

Core
Layout: R & A Pos
VERIFIED FIXED
13 years ago
13 years ago

People

(Reporter: Gary van der Merwe, Unassigned)

Tracking

({testcase})

Trunk
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(9 attachments, 4 obsolete attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1

I have a xbl with Anonymous content (html:img and html:div) which displays a
shaddow on a box. 

When the element that the xbl is applied to has children with Anonymous content
(such as a <li>) the Anonymous content of the XBL dose not layout correctly.

I think that the following is happening.

code dose layout Anonymous content in xbl.
code dose layout Anonymous content in child elements.
dimensions of parent element change.
code dosenot re-layout Anonymous content in xbl. Anonymous content in xbl is now
not layout correctly.


If one resizes the window, a re-layout happens, and one can see the expected
results.

Reproducible: Always
Steps to Reproduce:
1.View example page (htmlpage1.htm)
2.Resize window to see expected results
3.
(Reporter)

Comment 1

13 years ago
Created attachment 156789 [details]
Testcase: Start Here
(Reporter)

Comment 2

13 years ago
Created attachment 156790 [details]
Testcase: Download this
(Reporter)

Comment 3

13 years ago
Created attachment 156792 [details]
Testcase: Download this XBL
(Reporter)

Comment 4

13 years ago
Created attachment 156793 [details]
Testcase: Download this Image
(Reporter)

Comment 5

13 years ago
Created attachment 156794 [details]
Testcase: Download this Image
(Reporter)

Comment 6

13 years ago
Created attachment 156795 [details]
Testcase: Download this Image
(Reporter)

Comment 7

13 years ago
Created attachment 156796 [details]
Testcase: Download this Image
(Reporter)

Comment 8

13 years ago
Created attachment 156797 [details]
Testcase: Download this Image
(Reporter)

Comment 9

13 years ago
Created attachment 156798 [details]
Testcase: Download this Image
(Reporter)

Comment 10

13 years ago
Created attachment 156799 [details]
Testcase: all files in one zip

Sorry about this fokes. My first bug report. 

I see it is a pain to download all the files for my testcase, so I have put
them in to on zip for you.
(Reporter)

Updated

13 years ago
Attachment #156789 - Attachment is obsolete: true
Attachment #156790 - Attachment is obsolete: true
Attachment #156792 - Attachment is obsolete: true
Attachment #156793 - Attachment is obsolete: true
Attachment #156794 - Attachment is obsolete: true
Attachment #156795 - Attachment is obsolete: true
Attachment #156796 - Attachment is obsolete: true
Attachment #156797 - Attachment is obsolete: true
Attachment #156798 - Attachment is obsolete: true

Comment 11

13 years ago
Created attachment 156800 [details]
xbl

Updated

13 years ago
Attachment #156800 - Attachment mime type: text/xml → application/xml

Comment 12

13 years ago
Created attachment 156801 [details]
test case

Updated

13 years ago
Attachment #156799 - Attachment is obsolete: true

Updated

13 years ago
Attachment #156793 - Attachment is obsolete: false

Updated

13 years ago
Attachment #156794 - Attachment is obsolete: false

Updated

13 years ago
Attachment #156795 - Attachment is obsolete: false

Updated

13 years ago
Attachment #156796 - Attachment is obsolete: false

Updated

13 years ago
Attachment #156797 - Attachment is obsolete: false

Updated

13 years ago
Attachment #156798 - Attachment is obsolete: false

Comment 13

13 years ago
Next time you make an attachment try to link them to each other. Try to make
your test case as minimal as possible. If images are not needed for showing the
bug, don't use them. Try to use CSS and JS inline. Small images could be
included using the data: URI scheme.
(<http://software.hixie.ch/utilities/cgi/data/data>)

Adding zip files won't help at all, no developer is going to check those.
Created attachment 156804 [details]
regular html testcase (no xbl)

I don't think this has anything to do with xbl. I can see the bug also with
this regular html testcase (no xbl used).
If you don't see the bug directly, do a shift->reload.

It has probably got something to do with the list-style-images causing a
different block size, which isn't somehow detected by the absolutely positioned
divs.

Seeing this with:
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a3) Gecko/2004-08-20
Firefox/0.9.1+
(Reporter)

Comment 15

13 years ago
Martijn Wargers has better diagnosed the problem. 

Can I change the Component to "Layout: R & A Pos" and the Summary to "Absolutely
positioned divs do not resize when list-style-images load"? 

Should I as the Reporter, change these fields?

Comment 16

13 years ago
Confirming and changing summary to match comment 15.
Status: UNCONFIRMED → NEW
Component: XBL → Layout: R & A Pos
Ever confirmed: true
Keywords: testcase
OS: Windows XP → All
Hardware: PC → All
Summary: Anonymous content for XBL not laying out correctly if element contains other Anonymous content → Absolutely positioned divs do not resize when list-style-images load

Updated

13 years ago
Assignee: hyatt → nobody
QA Contact: ian → core.layout.r-and-a-pos
(Reporter)

Comment 17

13 years ago
I noticed some more information.

You will see in my original testcase, I have a hover style for the li's. As I
hovered over the first Li, I saw that it was also incorectly positioned. It's
right border was next to the shadow div, not the right border of the ul.

I have not been able to reproduce this behaviour.
Looks like another manifestation of bug 175364
Depends on: 175364
(Reporter)

Comment 19

13 years ago
I'm going to have a go at this. Busy trying to Build.
Fixed by checkin for bug 261064
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
(Reporter)

Comment 21

13 years ago
Just downloaded the latest tunk, and it's working! - Very cool.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.