If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Thunderbird gets confused with Planet Mozilla feed

RESOLVED FIXED

Status

MailNews Core
Feed Reader
RESOLVED FIXED
13 years ago
9 years ago

People

(Reporter: Doug Wright, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2) Gecko/20040822 Firefox/0.9.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2) Gecko/20040822 Firefox/0.9.1+

It often gets the sender wrong (e.g Daniel Glazman authors Mitch Kapors
entries??). Also many entries won't load.

Reproducible: Always
Steps to Reproduce:
(Reporter)

Comment 1

13 years ago
Created attachment 157354 [details]
Screenshot showing various problems

My original summary could have been clearer :-)

I don't know whether it's Thunderbird's fault, or Planet Mozilla but....

1)Some entries have a 'website' URL of the form 123@http://www.foo.bar.com/
Thus the entry doesn't load.
2)Some entries appear many times.
3)Some entries have an incorrect author.

I can discern no pattern to whether any particular problem appears on any
particular post. Some are OK, some have 1 or 2, some have all 3!

The screen shot shows all 3 problems. If it is a Thunderbird bug, then it
should probably block 0.8
(Assignee)

Comment 2

13 years ago
I fixed part of this problem where the guid was being used for the Website URL
instead of the link. 

The remaining issues seem to be related to the feed. Various entries don't have
author attributes on them so we get the author wrong because there isn't one....
(Reporter)

Comment 3

13 years ago
OK, sounds good. but..

1)Why not <unknown> instead of copying another (random?) author?
2)The duplicate entries don't appear to be in the feed - so this part is still a
TB problem I believe.
(Assignee)

Comment 4

13 years ago
The 2nd problem is that some of the feeds don't have a <creator> (i.e. author)
tag so Thunderbird looks outside of the article to see if the channel itself has
an author. This results in posts without authors to get the first author in the
xml document
(Assignee)

Comment 5

13 years ago
Created attachment 157848 [details] [diff] [review]
fix the problem with wrong authors being used

We no longer search through the channel for an author when the article doesn't
include one for RSS 2.0 feeds. We fall back to the feed title (Mozilla Zine
Feedhouse).

The only remaining issues is duplicate entries which I haven't been able to
reproduce yet. Let's track that in a separate bug.
(Assignee)

Comment 6

13 years ago
both of the fixes went into the branch and the trunk.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird0.8
(Reporter)

Comment 7

13 years ago
Have you filed a bug for the duplicate entries? Or do you want me to do it?

Comment 8

13 years ago
Doug, did you file a bug on the duplicate entries? Still see this with 0.9

If not let me know please
(Reporter)

Comment 9

13 years ago
Yeah - bug 258465

Updated

9 years ago
Component: RSS → Feed Reader
Product: Thunderbird → MailNews Core
Target Milestone: Thunderbird0.8 → ---
You need to log in before you can comment on or make changes to this bug.