Download manager should store download file sessions for later use like third-party download managers

VERIFIED DUPLICATE of bug 230870

Status

()

--
enhancement
VERIFIED DUPLICATE of bug 230870
14 years ago
10 years ago

People

(Reporter: dmynyk, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3

Although the Download Manager allows you to pause and resume your download while
Firefox is running, it would be nice (VERY nice) if Firefox's own download
manager allowed you to close all Firefox windows, and any downloaded files would
automatically stop and partial files will remain on your drive, and their
session information would remain with Firefox's Download Manager to continue
downloading at a later time. You should not have to finish or cancel all current
downloads before closing Firefox. If third party download managers can do this,
it would be very convenient if Firefox's own download manager could do this. It
would make downloading large files much more pleasant.

Reproducible: Always
Steps to Reproduce:
1. Begin downloading a file
2. Close Firefox
3. The download must be canceled for Firefox to close

Actual Results:  
I could not save my download session for later use without closing Firefox.

Expected Results:  
Firefox should store my download sessions so that I can close Firefox, reboot my
computer, run Firefox later, and resume those downloads from the same spot I
last left them without redownloading from the beginning.

I don't think this is my original idea, but I couldn't find a bug in the list
that read similarly, without searching for hours.
(Reporter)

Comment 1

14 years ago
Of course, don't deny the user a preference, maybe an initial dialog before
closing the last window the first time. Something like:

--------------------------------------------
|  You still have # unfinished downloads.  |
|  What would you like to do?              |
|                                          |
|  (*) Save download session and resume    |
|      later                               |
|  ( ) Cancel all downloads                |
|                                          |
| [x] Make this the default option         |
|                                          |
|  (Close Firefox)  (Do not close Firefox) |
--------------------------------------------
(Reporter)

Comment 2

14 years ago
This option should also be accessible through
Tools->Options->Downloads->Download Manager group
(Reporter)

Comment 3

14 years ago

*** This bug has been marked as a duplicate of 230870 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.