If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

It is not possible to show the Tab Bar when only one tab is open, and Tab Bar menu item behaves incorrectly

RESOLVED WORKSFORME

Status

SeaMonkey
Tabbed Browser
--
major
RESOLVED WORKSFORME
13 years ago
9 years ago

People

(Reporter: Chris Carter, Unassigned)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.2) Gecko/20040803
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.2) Gecko/20040803

It is only possible to have the browser 'tab bar' displayed when there is more
than one 'tab' (i.e. more than one open page). This is different behaviour to
Netscape 7.x for example, where the tab bar could be displayed or hidden
independent of the number of tabbed windows open. It is also confusing because
when the tab bar is hidden, so is the handy button to open a new tab. I could
use CTRL+T or right-click on a link and select 'Open in new tab', but why not
just have the tab bar stay in place? Because this behaviour is different from
Netscape 7.x (which I upgraded from) I am assuming this is a bug and not a
strange 'feature'.

Closely related is the fact that the Tab Bar item under the View > Show|Hide
menu is permanently greyed out, although the checkmark indicator seems to work
(it is checked when the tab bar is opened by other means, for example). However
if the tab bar is open, you cannot close it using this menu selection. Nor can
you open it using the menu selection if it is closed.

Reproducible: Always
Steps to Reproduce:
1. Open a Mozilla browser - you get one page with no tab bar
2. 'View' menu > 'Show|Hide' > 'Tab Bar' will be grayed out
3. You cannot make the tab bar visible by selecting the 'Tab Bar' item
4. Open another tab, for example with CTRL+T
5. Try to make the tab bar disappear with 'View' > 'Show|Hide' > 'Tab Bar' - you
will not be able to

Conclusion - tabbed browsing controls are broken in the menu.

Actual Results:  
You are unable to properly control tabbed browsing from the 'View' > 'Show|Hide'
menu.

Expected Results:  
It should allow the tab bar to be summoned or dismissed according to the setting
of the 'Tab Bar' menu item. This item should not be permanently grayed out. It
should respond to user input.

I am using the 'Modern' theme.

Comment 1

13 years ago
Edit->Preferences->Navigation->Tabbed Browsing

Tab Display
[ ] hide the tab bar when only one tab is open

If this box is unchecked, you´ll see the tab bar also if there is only one tab
open. If you try to delete this tab with the x at the end of the tab bar, the
tab bar is killed. If you then load a 2nd tab, it is displayed again, and stays
open, when you have only one tab in the tab bar, until you try to kill this again.

[x] select new tabs opened from links

new wording, formerly known as 'load links in the background'

When you middle-click on a link, a new tab is generated, and the link is loaded.
this box checked means: the old tab is left, the new tab is shown
this box unchecked means: you can go on reading the current page, and switch to
the new tab whenever you want.
My favourite setting, because I want to finish reading an article, while I´m
loading some links from it.

Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.