Closed Bug 256675 Opened 18 years ago Closed 13 years ago

Talkback does not make it clear that it's for reporting crashes

Categories

(Core Graveyard :: Talkback Client, defect)

1.7 Branch
x86
All
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: jruderman, Assigned: jay)

References

Details

Talkback never says anything like "Firefox has crashed".  This has caused
several users to think that QFA *caused* Firefox to crash.

The closest Talkback comes to telling users what is going on is:

* "The Mozilla Quality Feedback Agent gathers predefined technical information
about Firefox and sends it back to the Mozilla software development so we can
improve future versions."  (Setup step 1.)

* "The Mozilla Quality Feedback Agent has captured information that Mozilla
needs to help improve Firefox's quality."  (Final dialog.)

Screenshots: http://www.squarefree.com/talkback/

Ideally, we would like users to understand:
* Firefox has crashed.
* Pressing "Send" sends technical information to Firefox developers, which will
help them make future versions of Firefox crash less.

I don't know how it should be worded.
OS: Windows XP → All
*** Bug 260389 has been marked as a duplicate of this bug. ***
*** Bug 254522 has been marked as a duplicate of this bug. ***
More examples of confusion: bug 218171, bug 219686, bug 208899, bug 212689.
This bug needs to be reassigned to someone that can get the wording right.
Cc'ing chofmann and asa...
note that it historically has been possible to send a report that isn't 
associated with a crash, as long as that's possible, the dialog should not 
incorrectly label that :).
(In reply to comment #5)
> note that it historically has been possible to send a report that isn't 
> associated with a crash, as long as that's possible, the dialog should not 
> incorrectly label that :).

One of the problems here is that the OS window is on top of the QFA.  This adds
confusion - makes it unclear as to what really crashed - unless one really isn't
**** off because his/her work was just toasted and can really read the
pop-ups.  Maybe the name Quality Feedback Agent isn't a great choice (Wish I
could offer a better one).  Or maybe get the QFA's pop-up on top of the OS's. 
In effect there are two dialogs fighting for the user at a time when the user
wants neither.
Cc'ing Shiva.  I recall talking with him about somehow disabling the MS crash
window when Talkback is triggered.   Not sure if it's possible, but worth
hearing from him if he has any info on the subject.  
See also bug 207452, "Call AddERExcludedApplication to disable Windows XP's error reporting for Mozilla".
There are a couple of problems that I see here. The first is that the QFA installs itself on first-run, and the second is that it doesn't have the clearest experience when it opens up to gather and send information.

Some suggestions:
 - the QFA setup should happen silently during the install process
 - a small dialog (see below) should appear after a crash event that asks
      - if the QFA can send the event
      - if the user wants to add notes (talkback4.png)
      - if the user wants the QFA to never show up again
 - if the user runs the QFA manually from the filesystem, it should
   always just jump right to the "send with notes" portion (talkback4.png)

Initial ASCII art:

 ,------------------------------------------------------------------,
 |  ,-.   Firefox experienced an error and was forced to close.     |
 | | X |                                                            |
 |  '-'   Information about this problem can be sent to Mozilla     |
 |        in order to improve the product in the future. None of    |
 |        your personal information has been captured or will be    |
 |        sent.                                                     |
 |                                                                  |
 |        [ ] Add your own comments to this report                  |
 |        [ ] Never send this type of information                   |
 |                                                                  |
 |           [ Send Information ]   [ Don't Send Information]       |
 |                                                                  |
 '------------------------------------------------------------------'

The window should be styled on w32 to look similar to the Microsoft/Dr. Watson crash reporter, and yes, assuming it doesn't get us into trouble, we probably should disable that MS window to avoid further confusion.
it really shouldn't say "Mozilla" (that's software, it doesn't receive talkback reports), maybe "Mozilla Corporation", or "mozilla.org".
I was stumped on that as well, but "Mozilla Corporation" is incorrect, since the information is visible to anyone working on the project; "mozilla.org" on the other hand, is meaningless to users. Let's iterate on the UE for now, and finalize the issue later (it probably needs some cbeard/pkim/hecker attention)
Some of the information is available to anyone working on the project, but email addresses and some technical details (e.g. register data) are only available to Mozilla Corporation employees.
(In reply to comment #10)
> it really shouldn't say "Mozilla" (that's software, it doesn't receive talkback
> reports), maybe "Mozilla Corporation", or "mozilla.org".

Thinking more on this, I think this concern isn't really valid. Mozilla is the public brand we're presenting, and the best fit for this dialog.
Blocks: 358308
*** Bug 362634 has been marked as a duplicate of this bug. ***
Perhaps it should say "Mozilla Firefox developers" in place of "Mozilla Corperation" or "mozilla.org". (Of course, switching "Mozilla Firefox" with the brand name of the application that crashed.)
Product: Core → Core Graveyard
Talkback is totally gone now.  Breakpad does a much better job here.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.