update.mozilla.org move to iguana

VERIFIED FIXED

Status

addons.mozilla.org Graveyard
Public Pages
--
major
VERIFIED FIXED
13 years ago
2 years ago

People

(Reporter: jay, Assigned: wolf)

Tracking

Details

(Reporter)

Description

13 years ago
With Firefox 1.0 PR approaching, we need to get the update website moved to the
new server as soon as possible so that we can be ready for the release.  We are
still having some performance/stability problems on rodan, so it will be nice to
get iguana setup quickly so we can test everything soon.

I have done my part, with the help of Myk, to get most of the software
installed.  Right now, we have the following setup and running on
iguana.mozilla.org:

RPM installs
1. Apache 2 (httpd-2.0.46-32.ent.3)
2. PHP 4 (php-4.3.2-11.1.ent srpm compiled with zziplib, gd2 and mysql support)
3. Java SDK (j2sdk-1_4_2_05-linux-i586.rpm)

Other intalls
1. Tomcat 5 (jakarta-tomcat-5.0.27.tar.gz)
2. Axis (axis-1_1.tar.gz)

I have configured Tomcat and Apache to use the jk2 connector so that we can do
all webserver/webservices administratin through the Apache conf.  Still learning
more about exactly what we can/cannot do while using the jk2 connector.

Things left to do:
1. Install the update.mozilla.org website pages/scripts (Wolf)
2. Setup update db on mecha (Myk/Wolf)
3. Security related stuff (Myk/Dan)?
(Assignee)

Comment 1

13 years ago
OK, I've landed/copied the update scripts over. along with the stored files.
Most everything seems to be working fine.
The one bug I've found though. Why would a URL like this,
http://iguana.mozilla.org/extensions/install.php/autofill_0.2.xpi?id=184&vid=586
work on rodan but not iguana? On iguana it returns a 404. (The extra /filename
was used to remind browsers that they weren't downloading install.php :-) If I
remove it, it works fine, so its not major just strange. ) 

The only thing website related left to do, is to re-setup the rsync to the
ftp-mirrors, for the new server. (Though that may have to wait till the site
migrates)

Next thing needing to be done, seems to be moving the DB to mecha, myk? how do
you wanna proceed with that?
We need to prevent database changes for some period of time to allow me to dump
the database on rodan and copy it over to mecha.  Then u.m.o will have to be
reconfigured to use mecha instead of rodan.  We can do this today in the early
afternoon if that works.  Let me know.
(Assignee)

Comment 3

13 years ago
The website is moved, as is the DB, both to iguana. FTP sync'ing seems to be
working normally. I'd say this bug is fixed. :-)
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
(Assignee)

Updated

13 years ago
Component: Update → Web Site
Product: mozilla.org → Update
Version: other → unspecified
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.