wrong html tag display in viewsource

RESOLVED WONTFIX

Status

Core Graveyard
View Source
RESOLVED WONTFIX
13 years ago
8 years ago

People

(Reporter: raoul bhatia, Assigned: Doron Rosenberg (IBM))

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a3) Gecko/20040817
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a3) Gecko/20040817

if the html page contains a html tag like shown below, one quote (") is missing
after the id.

<a href="<plink id="10007.5497">" title="Impressum">

the result in viewsource is:

<a href="<plink id="10007.5497>" title="Impressum">

Reproducible: Always
Steps to Reproduce:
1. create html page with <a href="<plink id="10007.5497">" title="Impressum">
2. open the page in mozilla
3. view the pagesource

Actual Results:  
<a href="<plink id="10007.5497>" title="Impressum">

Expected Results:  
<a href="<plink id="10007.5497">" title="Impressum">

Comment 1

13 years ago
Hmm... how odd. 

I put a data url in that you can see the problem at.

Comment 2

13 years ago
Please use a less sloppy HTML. The second quote is closing the first quote, and
so the parser is doing some fixups to try to make a sense out of the tag-soup.

You can use <a href="<plink id='10007.5497'>" title="Impressum">
or &quot;

I am marking this WONTFIX because it is not a good use of anybody time to try to
fix viewsource for this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WONTFIX

Comment 3

13 years ago
Note: you can see precisely the fixups that have been by using
1. Ctrl+A (ie. Select All)
2. and then right-click and pick View Selection Source in the context menu.

This will show you the source after the fixups, as it is seen internally by Gecko.
Product: Browser → Seamonkey

Updated

8 years ago
Component: View Source → View Source
Product: SeaMonkey → Core Graveyard
You need to log in before you can comment on or make changes to this bug.