'\' in URL lead to page not found

RESOLVED INVALID

Status

SeaMonkey
General
RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: osavill, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3

We have an intranet where the URLs have been written as \foo\bar.htm . Using IE
and Opera these links are followed ok. With Mozilla / Firefox the \ is
translated to %5C and the link is appended to the current level URL.

E.g. the framset http://mka-compaq/g4d/htm/gprsframe.htm has a link is written
as src="\G4D\htm\default_info.htm". All the frames show "Not Found". When "This
frame --> Show only this frame" is selected the following is shown in the URL
bar: http://mka-compaq/g4d/htm/%5CG4D%5Chtm%5Cdefault_info.htm, which is why it
does not work. Removing the 'g4d/htm/' gives:
http://mka-compaq/%5CG4D%5Chtm%5Cgprs_stack.htm and the page shows correctly.

(N.B. Neither http://mka-compaq%5CG4D%5Chtm%5Cgprs_stack.htm nor
http://mka-compaq\%5CG4D%5Chtm%5Cgprs_stack.htm display a page either, whereas
they do in IE.)

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 192816 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

13 years ago
Mark this as a duplicate but please don't loose sight of the fact the the core 
problem in this report is that the src="\foo\bar.html" is appended to the end 
of the core URL, this is what causes the 404 - NOT the %5C. 
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 3

13 years ago
> However, it is the fact that the 
> src="\foo\bar.html" is appended to the end of the current URL that causes the 
> 404, not the %5C.

Because Mozilla doesn't recognize the \ or %5c as path separator and therefor
doesn't know the correct base URI and appends (wrongly) the URL. See bug 254169
comment 2 etc. and Bug 236440.

Other bugs are bug 32895 comment 29, Bug 93197. 
Product: Browser → Seamonkey
a "\" is invalid in an URL and must be escaped (Mozilla doesn that).
Opera and IE seem incoirrectly convert a "\" to a "/"

-> invalid
(Please correct the "\" in the page to "/"

Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.