link not accessible when right and left clip properties have pixel values

RESOLVED INVALID

Status

()

RESOLVED INVALID
15 years ago
15 years ago

People

(Reporter: will, Unassigned)

Tracking

({testcase})

Trunk
x86
Windows 98
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.2) Gecko/20040803
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.2) Gecko/20040803

A link inside an abolutely positioned element with the clip property set to a
rect  with non-auto values for left and right is not accessible via the mouse.

Reproducible: Couldn't Reproduce
Steps to Reproduce:
1. Go the the test page: http://odin.himinbi.org/tests/test_set_clip.html
2. Select "Set Clipped Left and Right"
3. Try to click link

Actual Results:  
Link does not cause a change in the cursor and is not clickable.

Expected Results:  
Allowed me to click the link. I can do so for any of the other settings of the
clip property.
(Reporter)

Comment 1

15 years ago
Created attachment 156994 [details]
Testcase listed in report
You have set up the left clip edge to the right of the right clip edge.
This works (leaving 160px visible):

      <input type="button" style="background-color: lightblue" value="Set
Clipped Left and Right"
       onclick="setClip('auto', (window.innerWidth / 2 + 80) + 'px',
                        'auto', (window.innerWidth / 2 - 80) + 'px')">
      </input>


See http://www.w3.org/TR/CSS21/visufx.html#propdef-clip

-> INVALID
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Keywords: testcase
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.