Closed Bug 256958 Opened 17 years ago Closed 17 years ago

ISO encoded comma in From:-header confuses mailnews; answers are send to a seccond (wrong) address

Categories

(SeaMonkey :: MailNews: Message Display, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 254519

People

(Reporter: nhb_web, Assigned: sspitzer)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-AT; rv:1.8a3) Gecko/20040817
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-AT; rv:1.8a3) Gecko/20040817

This From:-header confuses mozilla because of the encoded comma:
From: =?iso-8859-1?Q?D=F6rge=2C_Michael?= <someone@example.com>

It decodes to "Dörge, Michael <someone@example.com>". The comma, however, is not
escaped. MailNews dispay the name "Dörge" in the message list and the string
"Michael <someone@example.com>" in the gray bar beetween message-list and message.

Answers are sent to Dörge@exmaple.com and Michael <someone@example.com>

Reproducible: Always
Steps to Reproduce:
1. Receive a mail with an MIME-encoded comma in the from header.
2. Look at the from column in the message list and the gray bar above the message
3. Try to answer the message and have a look at the to-headers.

Actual Results:  
From-header is split at the comma.

Expected Results:  
From-header should be treated as one unit (escaping the comma by putting the
complete name in quotes if necessary)
Looks like a duplicate of Bug 254519.
I agree.

*** This bug has been marked as a duplicate of 254519 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.