Need compressed xpis in windows-xpi and linux-xpi dirs on FTP

RESOLVED FIXED in mozilla1.7.4

Status

()

Toolkit
Application Update
P1
normal
RESOLVED FIXED
14 years ago
10 years ago

People

(Reporter: Ben Goodger (use ben at mozilla dot org for email), Assigned: Brian Ryner (not reading))

Tracking

({fixed-aviary1.0})

unspecified
mozilla1.7.4
fixed-aviary1.0
Points:
---
Bug Flags:
blocking-aviary1.0PR +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [have patch] - running on tinderb's)

When we build the installer, we should also generate compressed (zip -9) xpis in
addition to the stored xpis (zip -0) and place them in windows-xpi and
linux-xpi. Mac can come later. This is a prerequisite for software update.
Flags: blocking-aviary1.0PR+
Priority: -- → P1
Target Milestone: --- → Firefox1.0beta
*** Bug 256935 has been marked as a duplicate of this bug. ***

Comment 2

14 years ago
chofmann asked me to look at this.

so we want to generate two of each xpi for each build, one compressed and one
uncompressed?  where are these files supposed to go and what should they be
named to differentiate them from each other?

Updated

14 years ago
Keywords: fixed-aviary1.0
Whiteboard: [have patch] - running on tinderb's

Comment 3

14 years ago
this is fixed, isn't it (stage is down and I can't get through to mecha so
checking is difficult)?  we do stored xpis for doing the blob installer and
compressed xpis for the *-xpi directory.

Comment 4

13 years ago
does this bug still need to be open?

Comment 5

13 years ago
This is fixed: browser.xpi has 5.0MB, the files it contains take up more than 11 MB.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.