Identity manager is missing for movemail accounts.

RESOLVED FIXED in mozilla1.8alpha5

Status

RESOLVED FIXED
14 years ago
14 years ago

People

(Reporter: volkmar, Assigned: Stefan.Borggraefe)

Tracking

({fixed-aviary1.0, regression})

Trunk
mozilla1.8alpha5
x86
Linux
fixed-aviary1.0, regression
Bug Flags:
blocking-aviary1.0 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2) Gecko/20040825 Firefox/0.9.1+
Build Identifier: thunderbird-i686-linux-gtk2+xft.tar.gz version 0.7+ (20040825)



Reproducible: Always
Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

14 years ago
Sorry for sending incomplete report!

In Thunderbird's Account Settings for Movemail accounts, options for all entries
of "default identity" are missing.
This way, users having just only one movemail account and nothing else have no
chance to set "Reply-to Adress" or "Signature File".

There is a text string saying: "The following is a special account. There are no
identities associated with it."

Nevertheless, the following prefs are generated, clearly showing the association
of "id1" with "server2":
user_pref("mail.account.account2.identities", "id1");
user_pref("mail.account.account2.server", "server2");

user_pref("mail.server.server2.directory",
"/home/username/.thunderbird/default/Mail/localhost");
user_pref("mail.server.server2.directory-rel", "[ProfD]Mail/localhost");
user_pref("mail.server.server2.download_on_biff", true);
user_pref("mail.server.server2.hostname", "localhost");
user_pref("mail.server.server2.login_at_startup", true);
user_pref("mail.server.server2.name", "foo@bar.tld");
user_pref("mail.server.server2.type", "movemail");
user_pref("mail.server.server2.userName", "username");

user_pref("mail.identity.id1.compose_html", false);
user_pref("mail.identity.id1.doBcc", false);
user_pref("mail.identity.id1.doBccList", "");
user_pref("mail.identity.id1.draft_folder", "mailbox://bodo@localhost/Drafts");
user_pref("mail.identity.id1.drafts_folder_picker_mode", "0");
user_pref("mail.identity.id1.fcc_folder", "mailbox://username@localhost/Sent");
user_pref("mail.identity.id1.fcc_folder_picker_mode", "0");
user_pref("mail.identity.id1.fullName", "- Full Linux Username -");
user_pref("mail.identity.id1.smtpServer", "smtp1");
user_pref("mail.identity.id1.stationery_folder",
"mailbox://username@localhost/Templates");
user_pref("mail.identity.id1.tmpl_folder_picker_mode", "0");
user_pref("mail.identity.id1.useremail", "bodo@kasper.tld");
user_pref("mail.identity.id1.valid", true);
Summary: Movemail prefs missing options in Accont → Movemail prefs missing options in Account Settings
(Reporter)

Updated

14 years ago
Summary: Movemail prefs missing options in Account Settings → Identity manager is missing for movemail accounts.
(Reporter)

Updated

14 years ago
Blocks: 253519
(Assignee)

Comment 2

14 years ago
Confirming. This is a regression from bug 250247.

Movemail should show am-main.xul, not am-serverwithnoidentities.xul and it did
before bug 250247 with fixed.
Assignee: mscott → Stefan.Borggraefe
Status: UNCONFIRMED → NEW
Component: Preferences → Account Manager
Ever confirmed: true
Keywords: regression
Product: Thunderbird → MailNews
Target Milestone: --- → mozilla1.8alpha5
Version: unspecified → Trunk
(Assignee)

Comment 3

14 years ago
Created attachment 160494 [details] [diff] [review]
Patch
(Assignee)

Updated

14 years ago
Attachment #160494 - Flags: superreview?(bienvenu)
Attachment #160494 - Flags: review?(mscott)
(Reporter)

Comment 4

14 years ago
Created attachment 160515 [details]
Account Settings" show "Local directory:" instead of "Signature file:"

Will this Bug 256969 also be fixed by that patch?
(Assignee)

Comment 5

14 years ago
*** Bug 256969 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 6

14 years ago
(In reply to comment #4)
> Created an attachment (id=160515)
> Will this Bug 256969 also be fixed by that patch?

Yup. :-) I just marked it as a dupe. Basically the wrong main preferences pane
is shown for Movemail accounts. My patch fixes this.

But bug 253519 is unrelated to this bug.
No longer blocks: 253519

Comment 7

14 years ago
Comment on attachment 160494 [details] [diff] [review]
Patch

thanks for cleaning up my mess Stefan.
Attachment #160494 - Flags: review?(mscott) → review+

Updated

14 years ago
Flags: blocking-aviary1.0+
Keywords: fixed-aviary1.0

Comment 8

14 years ago
Comment on attachment 160494 [details] [diff] [review]
Patch

nope, I didn't see this one either :-(
Attachment #160494 - Flags: superreview?(bienvenu) → superreview+
(Assignee)

Comment 9

14 years ago
Fix checked in.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.