Password not saved when accessing websites that use certificates (dod pki)

VERIFIED DUPLICATE of bug 256998

Status

()

Toolkit
Password Manager
VERIFIED DUPLICATE of bug 256998
14 years ago
10 years ago

People

(Reporter: Stephen Sizemore, Assigned: Brian Ryner (not reading))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3

I'm using Firefox Branch Build from August 25, 2004.

When I go to my Navy OWA website.  It prompts my from my username and password.
 The page loads, when I click an email, it asks my for my username and password
again.  

Background:

The Navy OWA website require a certificate to authenticate with the webserver. 
I have this certificate installed into firefox.  This works fine in Firefox
0.9.3 and in branch builds 8/20/2004 and earlier.

Reproducible: Always
Steps to Reproduce:
1.  Go go https://webmail.nmci.navy.mil/exchange/
2.  Enter Username and password
3.  Click on an email
4.  Username and password fields are blank.
5.  I'm forced to enter a username and password again.

Actual Results:  
I'm forced to enter my username and password serveral times to view email.

Expected Results:  
I should be able to enter my username and password once and able to use NMCI
webmail without re-entering my password.

I've tried this on serval computers.  I've tried it with both new and old profiles.

Other OWA websites work fine.  It just seems to be a problem with OWA websites
that require you to have a certificate installed to authenicate with the web server.

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 256998 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.