"Offline" icon disappears

RESOLVED WORKSFORME

Status

Core Graveyard
GFX: OS/2
RESOLVED WORKSFORME
14 years ago
9 years ago

People

(Reporter: Kevin Hill, Assigned: mkaply)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.8a3) Gecko/20040819 MultiZilla/1.6.4.0b
Build Identifier: Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.8a3) Gecko/20040819 MultiZilla/1.6.4.0b

If the browser is "offline", the icon in the lower right corner of the window
disappears.  To go online, I must use "File" and select "Work Online".  This
behavior is new to version 1.8a3 and it was NOT present in version 1.8a2.

I noticed this change, because the browser frequently starts up in "offline"
mode although I never use the browser in "offline" mode.  

Version 1.8a3 (Build 2004081709) under Windows XP does NOT exhibit either of
these problems. 

Reproducible: Always
Steps to Reproduce:
1.Select "File" and "Work Offline", or click on the "Online"icon in the lower
right corner of the browser window.

2.
3.

Actual Results:  
The "online/offline" icon disappeared in the lower right corner of the browser
window.

Expected Results:  
The "offline" icon should be displayed in the lower right corner of the browser
window.

Comment 1

14 years ago
Have you tested if using a fresh profile/no extensions/a standard theme fixes
the problem you see?
(Reporter)

Comment 2

14 years ago
(In reply to comment #1)
> Have you tested if using a fresh profile/no extensions/a standard theme fixes
> the problem you see?

Thanks for the suggestion.

I deleted  Mozilla using the uninstall option and re-installed ver 1.8a3 using
the installer and selecting to install ONLY the browser.  The icon in the lower
right was present and behaved normally.

I deleted the installation using uninstall and re-installed ver 1.8a3.  I
selected a custom installation and installed the browser + mail.  The icon in
the lower right corner was MISSING and behaved as in my original bug report.

I repeated this a number of times and any option to install more than the
browser resulted in the behavior noted in my original bug report.

I am currently running a full install of 1.8a2 without problem.

Thanks for your assistance. 

Comment 3

14 years ago
I followed your steps exactly with the 1.8a3 installer and installed browser and
mail only. After the start I selected both a fresh profile and one that already
existed. I do not see this on either of them. You didn't specifically say that
your tried with a clean profile (you can create on from the ProfileManager object).
(Reporter)

Comment 4

14 years ago
(In reply to comment #3)
> I followed your steps exactly with the 1.8a3 installer and installed browser and
> mail only. After the start I selected both a fresh profile and one that already
> existed. I do not see this on either of them. You didn't specifically say that
> your tried with a clean profile (you can create on from the ProfileManager
object).

Thanks for your work !

I missed the significance of using a clean profile.   I created a clean profile
and, like you observed, I do not see the problem with the icon.  The behavior is
NORMAL.

I will add extensions like Multizilla, Preferential etc and see if the abnormal
behavior returns.

By the way, if I delete the new profile and revert to my old profile, the
problem is back.

Thanks again for your assistance.

Comment 5

14 years ago
Marking WFM then.

If this bug is caused by an extension you should report this to the author of
the extension.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

14 years ago
(In reply to comment #5)
> Marking WFM then.
> 
> If this bug is caused by an extension you should report this to the author of
> the extension.

This should close the investigation.  I started with a fresh profile and then,
while Mozilla was closed, one by one, renamed files (eg. bookmarks) and copied
the corresponding file from the original profile.  After each change, I started
Mozilla, checked the behavior of the icons, and then closed Mozilla.

After changing bookmarks.html, history.dat, localstore.rdf, mimetypes.rdf,
panels.rdf, prefs.js, and search.rdf Mozilla behaved NORMALLY.  I then installed
Multizilla and Preferential and the behavior remained NORMAL.  

At this point, I have an installation of ver. 1.8a3 that functions correctly
with the extensions I normally use (Multizilla and Preferential).  I do not know
what is corrupted in my original profile.

Thanks again for your assistance.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.