If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

In Composer, the anchor does not show in the correct fomat. It shows fine in the browser.

RESOLVED INVALID

Status

SeaMonkey
Composer
RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: cricket, Unassigned)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.2) Gecko/20040803
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.2) Gecko/20040803

Lines in html code:
<p>Please, give me <a class="loc" href="feedbackform.htm">feedback</a>!</p>

<h3><a class="loc" href="indexbotp.htm">Battle of the Planets</a></h3>
<h3><a class="loc" href="indexorig.htm">Original Works</a></h3>



Relevant lines in stylesheet:

BODY	{color: #ffffff;  background-color: #009900;    font-family: sans-serif;
padding: 0 5% 0 5%; text-align: center;}

A.loc:link,                .lnv {color: #ccffcc; background-color: #009900;
text-decoration: underline; padding: 0 2px 0 2px;}
A.loc:visited,             .lv  {color: #ffffff; background-color: #009900;
text-decoration: underline; padding: 0 2px 0 2px;}
A.loc:hover, A.loc:active, .lh  {color: #ffffff; background-color: #006600;
text-decoration: underline; padding: 0 2px 0 2px;}


It works fine in the browser, but in the editor it shows as the default font:
blue sans-serif. On hover, the background changes to #006600 properly, but the
foreground remains the wrong colour and font.





Reproducible: Always
Steps to Reproduce:
1. Open index.htm and select "Edit Page".

Actual Results:  
See Details.

This happens for Visited, Hover, and Link modes. Not sure about Active.

Expected Results:  
Show the links in white sans-serif for Visited, Hover and Active, and in light
green for Link (not-visited).
(Reporter)

Comment 1

13 years ago
The example site is now up -- the upload went smoother than anticipated.

Comment 2

13 years ago
-> Component: Editor: Composer

That's most likely because you have
Edit/Preferences.../Composer/New Page Settings/Reader's default colors (don't
set colors in page) radio button checked 
and that you have
Edit/Preferences.../Appearance/Colors/Link Colors/Unvisited Links => blue
If you modify your user's default values, then you'll modify these values
(defaults in page) in Composer as well.

WORKSFORME

Mozilla 1.8a3 build 2004082608 under XP Pro SP2 here.

Your page code also underlines links while my default setting does not underline
links: so I see your feedback link underlined on the web but in composer it is
not underlined.

"New Page Settings
New page preferences allow you to specify settings for colors and background
images that apply to every document you create."

Regarding the font-family of feedback, my Fonts/Sans-serif preference will
appear, will be used both on the web page and in Composer and I have 
"Allow documents to use other fonts" checkbox checked.
Your links inherit the css font-family declaration from the css body rule:
BODY	{color: #ffffff;  background-color: #009900;    font-family: sans-serif; 

Can you verify all this carefully please? and then report back if everything is
ok? Thanks.
Component: Layout → Editor: Composer

Comment 3

13 years ago
I have not heard back from you. I'm resolving this bug as INVALID because the
behavior you describe is clearly not a bug but rather an intentional feature.
The Help/Help Contents/Contents tab/Creating Web Pages/Composer Preferences/New
Page Settings/ says:
"Reader's default colors: Select this if you always want your pages to use the
color settings from the viewer's browser for text and link elements."

It also applies to underlining links.

Regarding font-family (sans-serif), I think what you see is what you requested
(what you edited in your stylesheet, due to inheritance).

Resolving as INVALID
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

13 years ago
I emailed you with my tests and comments, and the results of further tests, on
August 26. The email you sent me did not say where to send the results, so I
emailed it to bugzilla-daemon@mozilla.org and drunclear@hotmail.com.

The text of that email follows:

Thank you for your quick reply.

I tested your suggestions. They did not solve the problem.

The New Page settings are irrelevant, as I created the page in another program,
not sure which one. I did, however, try changing them and the browser appearance
settings, just to be sure.

I also tested to see if the problem was related to subclasses; it occurs even
when using the base class. (I removed the class and it it still displayed
differently between the browser and in Composer. The browser showed it correctly
[reverting to the A style], but Composer did not.)

The background colours appear to work fine, but I did not pay close attention
while testing.

Underlining has the same problems as the font colour.

(Details of tests are interspersed with your reply.)

If you like, I can email you the html and css pages. They are also up on
www.onebit.ca/cricket -- the upload today went smoother than anticipated.

Cricket / Sandy Schoen



At 04:06 PM 8/26/2004, you wrote:
http://bugzilla.mozilla.org/show_bug.cgi?id=257008


drunclear@hotmail.com changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |drunclear@hotmail.com
          Component|Layout                      |Editor: Composer




------- Additional Comments From drunclear@hotmail.com  2004-08-26 13:06 PDT -------
-> Component: Editor: Composer

> That's most likely because you have
> Edit/Preferences.../Composer/New Page Settings/Reader's default colors (don't
> set colors in page) radio button checked 

Yes, I do have the New Page Settings set to use the reader's default colours,
but that is not relevant to the page in question, which was created in another
program.

I created new test pages in composer with both options. The only difference is:
<body style="color: rgb(0, 0, 0); background-color: rgb(255, 255, 255);"
alink="#000088" link="#0000ff" vlink="#ff0000"> 
vs
<body>

My page has the following first lines:
<html>
<head>
<meta http-equiv="CONTENT-TYPE" content="text/html; charset=windows-1252">
<title>Cricket's Homepage</title>
<link rel="stylesheet" type="text/css" href="indexstyles2.css">
</head>
<body lang="en-US"> 

All colours in my page are done using the linked CSS page.

> and that you have
> Edit/Preferences.../Appearance/Colors/Link Colors/Unvisited Links => blue
> If you modify your user's default values, then you'll modify these values
> (defaults in page) in Composer as well.

My browser is set to "Always use the colors and background specified by the web
page", so it should not override the code. (I do, however, want my page to allow
users to override -- a friend is colour-blind.)

I tested changing my browser to show the links as fuschia; Composer shows them
as fuschia -- again, despite the facts that:
1. the CSS code says they should be white or light green
2. the browser is set to use the colours specified by the web page
3. they show just fine in this browser and in Explorer


> WORKSFORME

> Mozilla 1.8a3 build 2004082608 under XP Pro SP2 here.

> Your page code also underlines links while my default setting does not 
> underline
> links: so I see your feedback link underlined on the web but in composer it 
> is
> not underlined.

Tested that, too. The CSS code underlines the links in the browser, but Composer
does not listen to the CSS. (Composer uses the settings for the browser, even
though I set the browser to use the colours of the web page. I tested all the
combinations of this.)


> "New Page Settings
> New page preferences allow you to specify settings for colors and background
> images that apply to every document you create."

This is only for documents created initially by Composer.

(BTW, I am very glad that Composer does not "improve" my code the way Word and
StarOffice try to -- they add in all sorts of garbage that I don't want.)

> Regarding the font-family of feedback, my Fonts/Sans-serif preference will
> appear, will be used both on the web page and in Composer and I have 
> "Allow documents to use other fonts" checkbox checked.
> Your links inherit the css font-family declaration from the css body rule:
> BODY	{color: #ffffff;  background-color: #009900;    font-family:
> sans-serif; 

The font-family is working fine now, inheriting from the surrounding element
(feedback is in a P and is sans-serif; Battle of the Planets is in a H3 and is
serif.) I don't recall the exact problem.

Additional: this was my mistake -- I had two versions of the stylesheet.

> Can you verify all this carefully please? and then report back if everything 
> is
> ok? Thanks.

Done.

++++++++


May I suggest that the emails sent to us newbies include more specific
information on how to respond?

Sandy Schoen
Cricket

Comment 5

13 years ago
1- Do not send me emails. If you have, then stop.
2- I did not send you emails and I do not intend to. I think you're confusing
with Bugmail (Bugfile e-mail updates).
3- Bugzilla is a database for reporting what one thinks is a bug, for
determining+confirming if these are bugs, searching for duplicates, finding
causes, fixing real bugs in Mozilla software. 
Bugzilla is not a 24 hr help desk. 
Bugzilla is not a support forum or a discussion newsgroup or a newbie channel. 
The Help/Help Contents helpfiles can be read at any time for support issues.
4- The more people make bugfiles long, unneedlessly long with all kinds of
unneedlessly pasted comments, the more people stay away from such bugfile:
reporter, bug triagers, assigner, developers, module owners, drivers, project
managers, etc... 
5- Everyone involved in bugzilla are volunteers, not paid people. Right now,
over 8,000 bugs (product: Browser and Firefox) are UNCONFIRMED and going over
each one of them takes time, volunteer time.
6- You say "Yes, I do have the New Page Settings set to use the reader's default
colours". The setting says "Reader's default colors (Don't set colors in page)".
The setting is about default page appearance. You chose and checked that
setting. The helpfile says "Reader's default colors: Select this if you always
want your pages to use the color settings from the viewer's browser for text and
link elements."

What more explanations do you need?? 
What's so difficult to accept, to understand here??

7- When you want to see your page the way it will look to a viewer (unless you
actively, intentionally and deliberately override this yourself with your own
prefs, ie see "Use my chosen colors, ignoring the colors and background image
specified"), then click the Browse button. 
"To view your page in a browser window in order to test your links:
* Open the File menu and choose Browse Page (or click Browse in the Composition
toolbar)."
Help/Help Contents/Contents tab/Creating Web Pages/Starting a New Page/Saving
and Browsing Your New Page
"Note: JavaScript functions, frames, links, Java, embedded objects and animated
GIF files are not active in any of the editing modes. To display these items in
their active state, click the Browse button on the Composition toolbar to load
the page into a browser window."
Help/Help Contents/Contents tab/Creating Web Pages/Formatting Your Web
Pages/Choosing the Right Editing Mode

8- Bug writing guidelines
http://www.mozilla.org/quality/bug-writing-guidelines.html
(Reporter)

Comment 6

13 years ago
I'm still convinced it's a bonafide bug.

The WYSIWYG edit view of an existing page using CSS does not look the same as
the regular view, even with the settings you suggested.

Browser is correct: Green background and white and green links. (Explorer also
shows it correctly.)

Composer is incorrect: Green background and blue links.

The settings were: 
Browser: "Always use the colors and backgrounds specified by the web page."
Composer: I tried both settings, including setting the colors to shades of
orange to be sure where colors were coming from.

The Composer page still showed in green with blue links. There was no orange.

If it were functioning correctly but I misunderstood the settings, both or
neither would be over-ridden.

A very, very low priority bug, but one worth being aware of if someone is
already looking at that section of the code.

The example page is www.onebit.ca/cricket. All colors are set using a linked CSS
stylesheet.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.