Wheel mouse is not working / A4Tech dual wheel mouse

VERIFIED DUPLICATE of bug 20618

Status

SeaMonkey
General
P3
normal
VERIFIED DUPLICATE of bug 20618
18 years ago
13 years ago

People

(Reporter: empeg, Assigned: Brian Ryner (not reading))

Tracking

({pp})

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
A4Tech dual wheel mouse is not working (wheels are not working at all)
in both enhanced and Intelli Mouse compatible mode
Drivers version is 5.3

Comment 1

18 years ago
Not sure which bug to DUP this off on...

Changing Product from "Arcchitecture" to "Browser"
Assignee: waterson → bryner
Component: All → Browser-General
Product: Architecture → Browser
QA Contact: shaver → janc
Version: 5.0 → other

Comment 2

18 years ago
What build is this on?

Comment 3

18 years ago
Updating summary
Summary: Wheel mouse is not working → Wheel mouse is not working / A4Tech dual wheel mouse

Comment 4

18 years ago
Reporter replied by email: build was M13.

Comment 5

18 years ago
This is probably the same issue that's affecting some Logitech mice.  Does this
mouse have a program that runs in the background (similar to logitech's
em_exec), and if so, does killing that program help at all?
Status: NEW → ASSIGNED

Comment 6

18 years ago
Assigning to M15 to match Logitech bug.
Target Milestone: M15

Updated

18 years ago
Keywords: 4xp, pp

Comment 7

18 years ago
Same problem here, with an "Connection" (=IntelliMouse compatible) wheel mouse. 
build 03/05
Yes, it has a seperate programm running in WIn95 in the background to enable the 
wheel. No it doesn't help to close that program (execpt for disabling the wheel 
in whole Win)

Comment 8

18 years ago
*** Bug 30959 has been marked as a duplicate of this bug. ***

Comment 9

18 years ago
*** Bug 30947 has been marked as a duplicate of this bug. ***

Comment 10

18 years ago
New observation:
The mouse wheel works! But *only* in select objects, where you can scroll the 
entries. It won't even work in e.g. textareas.
It will stop working there when I close the mouse driver program. Does anybody 
else see this with IntelliMouse (compatible) mice?
build 03/05 (and M14), don't know how long that has been working this way.

Comment 11

18 years ago
There are currently problems with mousewheel scrolling (on all platforms) when
the pointer is over a text area.  This will need some special handling.

It likely works in select areas because it's locating the native scrollbar
there.  This will go away soon.  But, I have some code that might help the
situation that I will be checking in after the beta branch is created.

Comment 12

18 years ago
Beginning with the 03-16-2000 M15 builds, you can do the following to generate
mousewheel debugging information (on Windows):

set NSPR_LOG_MODULES=MOUSEWHEEL:5
mozilla > mozilla.log

Mousewheel debugging information will have this format:
1024[80589f0]: (message)

Note that the numbers may differ.  If you are having the problems described in
this bug, and see any of these messages in the generated mozilla.log, please
attach the log to this bug report.  If you don't see these messages, the problem
is the app not getting the event in the first place (which is what I suspect,
but I want to be sure).

Comment 13

18 years ago
For what it's worth, I checked in some code today to let mozilla recognize
MSH_MOUSEWHEEL messages that are apparently generated by some mouse drivers on
Win95.  Might make scrolling work in some cases where it did not before.  This
will show up with the next nightly builds, which will be 3-20, I think.

Comment 14

18 years ago
You might want to look at comments I just added to bug 20618 about how to get 
even more debugging output.

Updated

18 years ago
Target Milestone: M15 → M16

Comment 15

18 years ago
*** Bug 35415 has been marked as a duplicate of this bug. ***

Comment 16

18 years ago
empeg@hot.pl- can you try this again in a recent nightly (04-12-2000-M16 or
later)?  I checked in a change that might affect this, but I'm not sure.
(Reporter)

Comment 17

18 years ago
it's working correctly now
i've got latest (from few hours) m16 build with beta a4tech drivers
for win2k
empeg@hot.pl

Comment 18

18 years ago
Marking fixed per reporter comment.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Updated

18 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 19

18 years ago
its not working again with final a4tech drivers (v 7.0) for win2k

Comment 20

18 years ago
If you reinstall the beta drivers, does it work?
(Reporter)

Comment 21

18 years ago
the problem is in a4tech software supporting double-click etc.
with old one (software - not driver) mozilla is working correctly (but i've got 
problems with this exe)
with new one it's not working
OS: Windows NT → Windows 2000

Comment 22

18 years ago
Wait, so what is not working?  The software that translates the middle button to
double-click, or the wheel scrolling itself?
(Reporter)

Comment 23

18 years ago
With new software wheels in mozilla are not working, but it's working in all 
other applications. Old one (beta) is working with all applications (including 
mozilla).
The problem is (as always) in this software, becouse mozilla is working 
correctly with old software and with no software. 

Comment 24

18 years ago
Hm, I'm not sure what all I can do here.  Are there any configuration options in
this software that might be applicable?
(Reporter)

Comment 25

18 years ago
i think this problem is not in mouse software but in mozilla
becouse this software is working correctly with all windows application 
(excluding mozilla)
(Assignee)

Comment 26

18 years ago
Moving all my bugs to this email.
Assignee: bryner → bryner
Status: REOPENED → NEW
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED

Comment 27

18 years ago
M16 has been out for a while now, these bugs target milestones need to be 
updated.
(Assignee)

Comment 28

18 years ago
As I noted in 22794, I think it might be good to mark this a dup of 20618 and
use that one as a meta-bug to track win32 mousewheel nonfunctionality problems. 
The issues are probably the same across all of these bugs.  Anyone object or
have evidence that this is a separate bug?
Target Milestone: M16 → ---
(Assignee)

Comment 29

18 years ago
Mousewheel bug consolidation.

*** This bug has been marked as a duplicate of 20618 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → DUPLICATE

Comment 30

18 years ago
verified duplicate
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.