Offline/online switcher is not UI Grabble.

RESOLVED FIXED

Status

()

Core
Disability Access APIs
RESOLVED FIXED
13 years ago
13 years ago

People

(Reporter: Louie Zhao, Assigned: Louie Zhao)

Tracking

({access})

Trunk
x86
Linux
access
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Assignee)

Description

13 years ago
Steps to Reproduce:
1. Start Mozilla and GOK.
2. In GOK, click UI Grab.

Bug Observation:
There is no pointer to online/offline switcher at the right bottom of Mozilla
window.
(Assignee)

Comment 1

13 years ago
Created attachment 157131 [details] [diff] [review]
patch v1

Implement accessible for Offline/online switcher.

In this patch, also fix a bug of getNameCB. The current code cached the name
and won't change even the name of element in mozilla has changed.
(Assignee)

Updated

13 years ago
Attachment #157131 - Flags: review?(aaronleventhal)

Comment 2

13 years ago
Comment on attachment 157131 [details] [diff] [review]
patch v1

Make sure the spacing is correct for 
+    nsAccessibleWrap *accWrap =
+    NS_REINTERPRET_CAST(MaiAtkObject*, aAtkObj)->accWrap;
Attachment #157131 - Flags: review?(aaronleventhal) → review+
(Assignee)

Updated

13 years ago
Attachment #157131 - Flags: superreview?(Henry.Jia)

Comment 3

13 years ago
Comment on attachment 157131 [details] [diff] [review]
patch v1

sr=Henry
Attachment #157131 - Flags: superreview?(Henry.Jia) → superreview+
(Assignee)

Updated

13 years ago
Keywords: access

Updated

13 years ago
Blocks: 263575

Comment 4

13 years ago
*** Bug 240737 has been marked as a duplicate of this bug. ***

Comment 5

13 years ago
Patch checked in (with whitespace fixed).

Checking in accessible/src/atk/nsAccessibleWrap.cpp;
/cvsroot/mozilla/accessible/src/atk/nsAccessibleWrap.cpp,v  <-- 
nsAccessibleWrap.cpp
new revision: 1.19; previous revision: 1.18
done
Checking in xpfe/global/resources/content/bindings/general.xml;
/cvsroot/mozilla/xpfe/global/resources/content/bindings/general.xml,v  <-- 
general.xml
new revision: 1.33; previous revision: 1.32
done
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Created attachment 167223 [details] [diff] [review]
port to toolkit (checked in)

ports the general.xml part of the above patch to toolkit/
Attachment #167223 - Flags: review?(mconnor)

Updated

13 years ago
Attachment #167223 - Flags: review?(mconnor) → review+
Comment on attachment 167223 [details] [diff] [review]
port to toolkit (checked in)

toolkit port checked in
Attachment #167223 - Attachment description: port to toolkit → port to toolkit (checked in)
You need to log in before you can comment on or make changes to this bug.