Error in "/modules/plugin/base/src/" when trying to build Firefox with Apple GCC-3.5-tree-ssa

RESOLVED DUPLICATE of bug 294244

Status

()

--
blocker
RESOLVED DUPLICATE of bug 294244
14 years ago
13 years ago

People

(Reporter: MMx, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
as in bug 256994 and bug 257096, I got this error when trying to compile Firefox
with the Apple gcc-3.5-tree-ssa compiler:

in the file
"http://lxr.mozilla.org/mozilla/source/modules/plugin/base/src/ns4xPlugin.cpp"
(trunk, expect it to be the same in all live branches)

---------------8<------------------------------------
ns4xPlugin.cpp: In static member function `static void
ns4xPlugin::CheckClassInitialized()':
ns4xPlugin.cpp:262: error: invalid conversion from `NPError (*)(NPP_t*, const
char*, const char*)' to `void*'
ns4xPlugin.cpp:262: error:   initializing argument 1 of `void* FP2TV(void*)'
ns4xPlugin.cpp:265: error: invalid conversion from `NPError (*)(NPP_t*, const
char*, const char*, uint32, const char*, NPBool)' to `void*'
ns4xPlugin.cpp:265: error:   initializing argument 1 of `void* FP2TV(void*)'
ns4xPlugin.cpp:268: error: invalid conversion from `NPError (*)(NPStream*,
NPByteRange*)' to `void*'
ns4xPlugin.cpp:268: error:   initializing argument 1 of `void* FP2TV(void*)'
ns4xPlugin.cpp:271: error: invalid conversion from `NPError (*)(NPP_t*, char*,
const char*, NPStream**)' to `void*'
ns4xPlugin.cpp:271: error:   initializing argument 1 of `void* FP2TV(void*)'
ns4xPlugin.cpp:274: error: invalid conversion from `int32 (*)(NPP_t*, NPStream*,
int32, void*)' to `void*'
ns4xPlugin.cpp:274: error:   initializing argument 1 of `void* FP2TV(void*)'
ns4xPlugin.cpp:277: error: invalid conversion from `NPError (*)(NPP_t*,
NPStream*, NPError)' to `void*'
ns4xPlugin.cpp:277: error:   initializing argument 1 of `void* FP2TV(void*)'
ns4xPlugin.cpp:280: error: invalid conversion from `void (*)(NPP_t*, const
char*)' to `void*'
ns4xPlugin.cpp:280: error:   initializing argument 1 of `void* FP2TV(void*)'
ns4xPlugin.cpp:283: error: invalid conversion from `const char* (*)(NPP_t*)' to
`void*'
ns4xPlugin.cpp:283: error:   initializing argument 1 of `void* FP2TV(void*)'
ns4xPlugin.cpp:286: error: invalid conversion from `void* (*)(uint32)' to `void*'
ns4xPlugin.cpp:286: error:   initializing argument 1 of `void* FP2TV(void*)'
ns4xPlugin.cpp:289: error: invalid conversion from `void (*)(void*)' to `void*'
ns4xPlugin.cpp:289: error:   initializing argument 1 of `void* FP2TV(void*)'
ns4xPlugin.cpp:292: error: invalid conversion from `uint32 (*)(uint32)' to `void*'
ns4xPlugin.cpp:292: error:   initializing argument 1 of `void* FP2TV(void*)'
ns4xPlugin.cpp:295: error: invalid conversion from `void (*)(NPBool)' to `void*'
ns4xPlugin.cpp:295: error:   initializing argument 1 of `void* FP2TV(void*)'
ns4xPlugin.cpp:299: error: invalid conversion from `constJRIEnvInterface**
(*)()' to `void*'
ns4xPlugin.cpp:299: error:   initializing argument 1 of `void* FP2TV(void*)'
ns4xPlugin.cpp:302: error: invalid conversion from `_jobject* (*)(NPP_t*)' to
`void*'
ns4xPlugin.cpp:302: error:   initializing argument 1 of `void* FP2TV(void*)'
ns4xPlugin.cpp:306: error: invalid conversion from `NPError (*)(NPP_t*, const
char*, const char*, void*)' to `void*'
ns4xPlugin.cpp:306: error:   initializing argument 1 of `void* FP2TV(void*)'
ns4xPlugin.cpp:309: error: invalid conversion from `NPError (*)(NPP_t*, const
char*, const char*, uint32, const char*, NPBool, void*)' to `void*'
ns4xPlugin.cpp:309: error:   initializing argument 1 of `void* FP2TV(void*)'
ns4xPlugin.cpp:312: error: invalid conversion from `NPError (*)(NPP_t*,
NPNVariable, void*)' to `void*'
ns4xPlugin.cpp:312: error:   initializing argument 1 of `void* FP2TV(void*)'
ns4xPlugin.cpp:315: error: invalid conversion from `NPError (*)(NPP_t*,
NPPVariable, void*)' to `void*'
ns4xPlugin.cpp:315: error:   initializing argument 1 of `void* FP2TV(void*)'
ns4xPlugin.cpp:318: error: invalid conversion from `void (*)(NPP_t*, NPRect*)'
to `void*'
ns4xPlugin.cpp:318: error:   initializing argument 1 of `void* FP2TV(void*)'
ns4xPlugin.cpp:321: error: invalid conversion from `void (*)(NPP_t*,
OpaqueRgnHandle*)' to `void*'
ns4xPlugin.cpp:321: error:   initializing argument 1 of `void* FP2TV(void*)'
ns4xPlugin.cpp:324: error: invalid conversion from `void (*)(NPP_t*)' to `void*'
ns4xPlugin.cpp:324: error:   initializing argument 1 of `void* FP2TV(void*)'
ns4xPlugin.cpp:327: error: invalid conversion from `void* (*)(const NPUTF8*)' to
`void*'
ns4xPlugin.cpp:327: error:   initializing argument 1 of `void* FP2TV(void*)'
ns4xPlugin.cpp:330: error: invalid conversion from `void (*)(const NPUTF8**,
int32_t, void**)' to `void*'
ns4xPlugin.cpp:330: error:   initializing argument 1 of `void* FP2TV(void*)'
ns4xPlugin.cpp:333: error: invalid conversion from `void* (*)(int32_t)' to `void*'
ns4xPlugin.cpp:333: error:   initializing argument 1 of `void* FP2TV(void*)'
ns4xPlugin.cpp:336: error: invalid conversion from `bool (*)(void*)' to `void*'
ns4xPlugin.cpp:336: error:   initializing argument 1 of `void* FP2TV(void*)'
ns4xPlugin.cpp:339: error: invalid conversion from `NPUTF8* (*)(void*)' to `void*'
ns4xPlugin.cpp:339: error:   initializing argument 1 of `void* FP2TV(void*)'
ns4xPlugin.cpp:342: error: invalid conversion from `int32_t (*)(void*)' to `void*'
ns4xPlugin.cpp:342: error:   initializing argument 1 of `void* FP2TV(void*)'
ns4xPlugin.cpp:345: error: invalid conversion from `NPObject* (*)(NPP_t*,
NPClass*)' to `void*'
ns4xPlugin.cpp:345: error:   initializing argument 1 of `void* FP2TV(void*)'
ns4xPlugin.cpp:348: error: invalid conversion from `NPObject* (*)(NPObject*)' to
`void*'
ns4xPlugin.cpp:348: error:   initializing argument 1 of `void* FP2TV(void*)'
ns4xPlugin.cpp:351: error: invalid conversion from `void (*)(NPObject*)' to `void*'
ns4xPlugin.cpp:351: error:   initializing argument 1 of `void* FP2TV(void*)'
ns4xPlugin.cpp:354: error: invalid conversion from `bool (*)(NPP_t*, NPObject*,
void*, constNPVariant*, uint32_t, NPVariant*)' to `void*'
ns4xPlugin.cpp:354: error:   initializing argument 1 of `void* FP2TV(void*)'
ns4xPlugin.cpp:357: error: invalid conversion from `bool (*)(NPP_t*, NPObject*,
NPString*, NPVariant*)' to `void*'
ns4xPlugin.cpp:357: error:   initializing argument 1 of `void* FP2TV(void*)'
ns4xPlugin.cpp:360: error: invalid conversion from `bool (*)(NPP_t*, NPObject*,
void*, NPVariant*)' to `void*'
ns4xPlugin.cpp:360: error:   initializing argument 1 of `void* FP2TV(void*)'
ns4xPlugin.cpp:363: error: invalid conversion from `bool (*)(NPP_t*, NPObject*,
void*, constNPVariant*)' to `void*'
ns4xPlugin.cpp:363: error:   initializing argument 1 of `void* FP2TV(void*)'
ns4xPlugin.cpp:366: error: invalid conversion from `bool (*)(NPP_t*, NPObject*,
void*)' to `void*'
ns4xPlugin.cpp:366: error:   initializing argument 1 of `void* FP2TV(void*)'
ns4xPlugin.cpp:369: error: invalid conversion from `bool (*)(NPP_t*, NPObject*,
void*)' to `void*'
ns4xPlugin.cpp:369: error:   initializing argument 1 of `void* FP2TV(void*)'
ns4xPlugin.cpp:372: error: invalid conversion from `bool (*)(NPP_t*, NPObject*,
void*)' to `void*'
ns4xPlugin.cpp:372: error:   initializing argument 1 of `void* FP2TV(void*)'
ns4xPlugin.cpp:375: error: invalid conversion from `void (*)(NPVariant*)' to `void*'
ns4xPlugin.cpp:375: error:   initializing argument 1 of `void* FP2TV(void*)'
ns4xPlugin.cpp:378: error: invalid conversion from `void (*)(NPObject*, const
NPUTF8*)' to `void*'
ns4xPlugin.cpp:378: error:   initializing argument 1 of `void* FP2TV(void*)'
ns4xPlugin.cpp: In constructor `ns4xPlugin::ns4xPlugin(NPPluginFuncs*,
PRLibrary*, NPError (*)(), nsIServiceManagerObsolete*)':
ns4xPlugin.cpp:464: error: invalid conversion from `NPError (*)(char*, NPP_t*,
uint16, int16, char**, char**, NPSavedData*)' to `void*'
ns4xPlugin.cpp:464: error:   initializing argument 1 of `void* TV2FP(void*)'
ns4xPlugin.cpp:465: error: invalid conversion from `NPError (*)(NPP_t*,
NPSavedData**)' to `void*'
ns4xPlugin.cpp:465: error:   initializing argument 1 of `void* TV2FP(void*)'
ns4xPlugin.cpp:466: error: invalid conversion from `NPError (*)(NPP_t*,
NPWindow*)' to `void*'
ns4xPlugin.cpp:466: error:   initializing argument 1 of `void* TV2FP(void*)'
ns4xPlugin.cpp:467: error: invalid conversion from `NPError (*)(NPP_t*, char*,
NPStream*, NPBool, uint16*)' to `void*'
ns4xPlugin.cpp:467: error:   initializing argument 1 of `void* TV2FP(void*)'
ns4xPlugin.cpp:468: error: invalid conversion from `NPError (*)(NPP_t*,
NPStream*, NPReason)' to `void*'
ns4xPlugin.cpp:468: error:   initializing argument 1 of `void* TV2FP(void*)'
ns4xPlugin.cpp:469: error: invalid conversion from `void (*)(NPP_t*, NPStream*,
const char*)' to `void*'
ns4xPlugin.cpp:469: error:   initializing argument 1 of `void* TV2FP(void*)'
ns4xPlugin.cpp:470: error: invalid conversion from `int32 (*)(NPP_t*,
NPStream*)' to `void*'
ns4xPlugin.cpp:470: error:   initializing argument 1 of `void* TV2FP(void*)'
ns4xPlugin.cpp:471: error: invalid conversion from `int32 (*)(NPP_t*, NPStream*,
int32, int32, void*)' to `void*'
ns4xPlugin.cpp:471: error:   initializing argument 1 of `void* TV2FP(void*)'
ns4xPlugin.cpp:472: error: invalid conversion from `void (*)(NPP_t*, NPPrint*)'
to `void*'
ns4xPlugin.cpp:472: error:   initializing argument 1 of `void* TV2FP(void*)'
ns4xPlugin.cpp:473: error: invalid conversion from `int16 (*)(NPP_t*, void*)' to
`void*'
ns4xPlugin.cpp:473: error:   initializing argument 1 of `void* TV2FP(void*)'
ns4xPlugin.cpp:474: error: invalid conversion from `void (*)(NPP_t*, const
char*, NPReason, void*)' to `void*'
ns4xPlugin.cpp:474: error:   initializing argument 1 of `void* TV2FP(void*)'
ns4xPlugin.cpp:475: error: invalid conversion from `NPError (*)(NPP_t*,
NPPVariable, void*)' to `void*'
ns4xPlugin.cpp:475: error:   initializing argument 1 of `void* TV2FP(void*)'
ns4xPlugin.cpp:476: error: invalid conversion from `NPError (*)(NPP_t*,
NPNVariable, void*)' to `void*'
ns4xPlugin.cpp:476: error:   initializing argument 1 of `void* TV2FP(void*)'
ns4xPlugin.cpp:477: error: invalid conversion from `void (*)()' to `void*'
ns4xPlugin.cpp:477: error:   initializing argument 1 of `void* TV2FP(void*)'
ns4xPlugin.cpp: In destructor `virtual ns4xPlugin::~ns4xPlugin()':
ns4xPlugin.cpp:494: error: invalid conversion from `NPError (*)(char*, NPP_t*,
uint16, int16, char**, char**, NPSavedData*)' to `void*'
ns4xPlugin.cpp:494: error:   initializing argument 1 of `void free(void*)'
ns4xPlugin.cpp:496: error: invalid conversion from `NPError (*)(NPP_t*,
NPSavedData**)' to `void*'
ns4xPlugin.cpp:496: error:   initializing argument 1 of `void free(void*)'
ns4xPlugin.cpp:498: error: invalid conversion from `NPError (*)(NPP_t*,
NPWindow*)' to `void*'
ns4xPlugin.cpp:498: error:   initializing argument 1 of `void free(void*)'
ns4xPlugin.cpp:500: error: invalid conversion from `NPError (*)(NPP_t*, char*,
NPStream*, NPBool, uint16*)' to `void*'
ns4xPlugin.cpp:500: error:   initializing argument 1 of `void free(void*)'
ns4xPlugin.cpp:502: error: invalid conversion from `void (*)(NPP_t*, NPStream*,
const char*)' to `void*'
ns4xPlugin.cpp:502: error:   initializing argument 1 of `void free(void*)'
ns4xPlugin.cpp:504: error: invalid conversion from `int32 (*)(NPP_t*,
NPStream*)' to `void*'
ns4xPlugin.cpp:504: error:   initializing argument 1 of `void free(void*)'
ns4xPlugin.cpp:506: error: invalid conversion from `int32 (*)(NPP_t*, NPStream*,
int32, int32, void*)' to `void*'
ns4xPlugin.cpp:506: error:   initializing argument 1 of `void free(void*)'
ns4xPlugin.cpp:508: error: invalid conversion from `void (*)(NPP_t*, NPPrint*)'
to `void*'
ns4xPlugin.cpp:508: error:   initializing argument 1 of `void free(void*)'
ns4xPlugin.cpp:510: error: invalid conversion from `int16 (*)(NPP_t*, void*)' to
`void*'
ns4xPlugin.cpp:510: error:   initializing argument 1 of `void free(void*)'
ns4xPlugin.cpp:512: error: invalid conversion from `void (*)(NPP_t*, const
char*, NPReason, void*)' to `void*'
ns4xPlugin.cpp:512: error:   initializing argument 1 of `void free(void*)'
ns4xPlugin.cpp:514: error: invalid conversion from `NPError (*)(NPP_t*,
NPPVariable, void*)' to `void*'
ns4xPlugin.cpp:514: error:   initializing argument 1 of `void free(void*)'
ns4xPlugin.cpp:516: error: invalid conversion from `NPError (*)(NPP_t*,
NPNVariable, void*)' to `void*'
ns4xPlugin.cpp:516: error:   initializing argument 1 of `void free(void*)'
ns4xPlugin.cpp: In member function `virtual nsresult ns4xPlugin::Shutdown()':
ns4xPlugin.cpp:862: error: invalid conversion from `NPError (*)()' to `void*'
ns4xPlugin.cpp:862: error:   initializing argument 1 of `void free(void*)'
make[4]: *** [ns4xPlugin.o] Error 1
------------8<-----------------------

additional information about my compiler:

Reading specs from /usr/lib/gcc/powerpc-apple-darwin/3.5.0-tree-ssa/specs
Configured with:
/Volumes/FW_Jaguar/TEMP/Builds/GCC/gcc-1765/build/obj/src/configure
--disable-checking --prefix=/usr --disable-libmudflap --mandir=/share/man
--enable-languages=c,objc,c++ --disable-libada
--program-transform-name=/^[cg][^+.-]*$/s/$/-3.5/
--with-gxx-include-dir=/include/gcc/darwin/3.5/c++ --build=powerpc-apple-darwin
--host=powerpc-apple-darwin --target=powerpc-apple-darwin
Thread model: posix
gcc version 3.5.0-tree-ssa 20040321 (merged 20040529) (Apple Computer, Inc.
build 1765)

CCing people who last changed some of the lines in question.
(Reporter)

Comment 1

14 years ago
setting dependency on tracker bug
Depends on: 257100
(Reporter)

Updated

14 years ago
Blocks: 257100
No longer depends on: 257100

Comment 2

13 years ago

*** This bug has been marked as a duplicate of 294244 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.