System Requirements page out of date

RESOLVED FIXED

Status

www.mozilla.org
General
--
critical
RESOLVED FIXED
14 years ago
6 years ago

People

(Reporter: hacksaw, Assigned: Brian Ryner (not reading))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (compatible; MSIE 6.0; Windows NT 5.1)
Build Identifier: 

Of course, my first clue was that the system requirements page talks about gtk+
1.2.0, and the newest Linux build has GTK2 in the title. So I was prepared, or
so I thought. I have gtk2.0.4 installed on my system.

Then I installed firefox .9.3 onto my system.

/usr2/src/firefox/firefox-bin: error while loading shared libraries:
libstdc++.so.5: cannot open shared object file: No such file or directory

Yeah, no surprise there. I'm running a somewhat update RedHat 7.2 system. stdc++
5? Not a chance.



Reproducible: Always
Steps to Reproduce:
1. Download firefox for gtk2
2. install it on a redhat 7.2 system that has gtk2.0.4 installed
3. run it

Actual Results:  
It failed to find a needed library.



Expected Results:  
The website should have said what libraries I needed. Please note that telling
me I need a particular version of RedHat isn't very useful. Updating certain
things is possible, updating the system is a much larger problem.

Note that I am marking this bug as critical for an important reason: I blasted
my old firefox 0.8 install with this. I was lucky in that I have a backup of the
directory I was able to restore. Others might not be so lucky.

Comment 1

14 years ago
*** Bug 257231 has been marked as a duplicate of this bug. ***
The GTK2+Xft builds have newer requirements than the GTK1 builds.
*** Bug 258214 has been marked as a duplicate of this bug. ***
*** Bug 257490 has been marked as a duplicate of this bug. ***
bryner, could you update this to whatever the new requirements are?
Assignee: mozilla.webmaster → bryner
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 6

13 years ago
Looks like the page has been updated. I'll resolve this to fixed, and try and
verify it when I get home.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Comment 7

13 years ago
That page also mentions Mac OS X 10.1.x, but I think it's not true anymore (it
needs at least Mac OS X 10.2.x).
Product: mozilla.org → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.