Unable to select all links when many links are bundled together.

RESOLVED DUPLICATE of bug 102695

Status

()

defect
RESOLVED DUPLICATE of bug 102695
15 years ago
7 years ago

People

(Reporter: russellmcormond, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(1 attachment)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040706 Firefox/0.9.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040706 Firefox/0.9.1

At the page http://www.digital-copyright.ca/node/view/445 you will note that
there are many links ("General | Barrie | " ...etc).  With recent versions of
Mozilla or Firefox I am only able to select the links that are at the boundaries
(top, bottom, sides), but not the links in the middle.  With older versions of
Mozilla (Example V1.6) I am able to select all the links.

Reproducible: Always
Steps to Reproduce:
Status: UNCONFIRMED → NEW
Ever confirmed: true
Posted file Testcase
Removing "padding: 1.5em;" makes it work properly.
The top padding of the following line is covering up the line before it.

*** This bug has been marked as a duplicate of 102695 ***
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
(Note that the duplicate bug is possibly invalid.)
This is definitely valid - how can it be a dupe of something invalid?
I did as you suggested and commented out the padding in the CSS and it does seem
to work.  Thank you, and sorry for the false alarm.  Guess that will teach me to
trust stylesheets that come from third parties.

I'm now curious what the change is with the Mozilla codebase that the behaviour
changed from older versions to the newest version?

--- xtemplate.css-orig  2004-05-02 11:45:31.000000000 -0400
+++ xtemplate.css       2004-08-27 22:00:04.000000000 -0400
@@ -220,7 +220,7 @@
 .node .taxonomy {
   color: #999;
   font-size: 0.8em;
-  padding: 1.5em;
+  /* padding: 1.5em; */
 }
 .node .avatar {
   border: 1px solid #ddd;
You need to log in before you can comment on or make changes to this bug.