flag inclusions/exclusions do not work for Components that contain a : in the name

RESOLVED FIXED in Bugzilla 2.18

Status

()

Bugzilla
Administration
--
major
RESOLVED FIXED
13 years ago
13 years ago

People

(Reporter: Joshua Neveln, Assigned: Frédéric Buclin)

Tracking

unspecified
Bugzilla 2.18
Bug Flags:
blocking2.20 -
blocking2.18 -

Details

(Whiteboard: [blocker will fix] [wanted for 2.20])

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.7b) Gecko/20040514
Build Identifier: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.7b) Gecko/20040514

When adding and editing Flag inclusions and exclusions, Component names that
include a colon (:) are truncated to just the portion before the :.

The flag then is not properly included or excluded on the components.

Reproducible: Always
Steps to Reproduce:
1. Have a component name that includes a colon "comp: sub"
2. create or edit a flag.
3. Include the Product/Component pair that includes "comp: sub"
4. remove the "Any: Any" inclusion
5. Save Changes
6. Return to editing the flag

Actual Results:  
The inclusion list for the flag contains
<product>: comp

Also bugs in the component "comp: sub" do not include the flag.

Expected Results:  
Expect that bugs in the component "comp: sub" would contain the flag.

When editing the flag, the full component name would be in the inclusion list.
(Reporter)

Comment 1

13 years ago
Created attachment 157164 [details] [diff] [review]
Seems to fix the problem

Added simple looking attempt at fixing this.  

Unfortuantely due to firewall issues, I don't have access to the cvs repository
right now.  Did my fix on 2.17.6, but it seems to mostly apply to 2.18rc2,
though the line numbers are a bit different.
(Reporter)

Updated

13 years ago
Attachment #157164 - Flags: review?
(Reporter)

Comment 2

13 years ago
This also appears that it would be a problem if a Product name contains ":".

Comment 3

13 years ago
Comment on attachment 157164 [details] [diff] [review]
Seems to fix the problem

Hah. This is not actually solvable by restricting split, since both product and
component can contain colons in their names. No, the proper way to fix it is to
use a different data structure, I suspect.
Attachment #157164 - Flags: review? → review-

Comment 4

13 years ago
This is seriously whacked for products and components containing colons. I
witnessed all sorts of weirdness in CVS HEAD. Argh perl.
Severity: normal → major
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking2.18?
(Reporter)

Comment 5

13 years ago
The other option would be to put some check on product and component creation
preventing them from using colons.  I don't really like suggesting that though,
as I rather like having colons in the component names.
I will accept a backport to the 2.18 branch on this, but I'm not going to block
release for it.
Flags: blocking2.18? → blocking2.18-
Reassigning bugs that I'm not actively working on to the default component owner
in order to try to make some sanity out of my personal buglist.  This doesn't
mean the bug isn't being dealt with, just that I'm not the one doing it.  If you
are dealing with this bug, please assign it to yourself.
Assignee: justdave → administration
QA Contact: mattyt-bugzilla → default-qa
(Assignee)

Updated

13 years ago
Flags: blocking2.20?
(Assignee)

Updated

13 years ago
Assignee: administration → LpSolit
Depends on: 288663
OS: SunOS → All
Hardware: Sun → All
Whiteboard: [blocker will fix]
Target Milestone: --- → Bugzilla 2.18
"If it's not a regression from 2.18 and it's not a critical problem with
something that's already landed, let's push it off." - Dave
Flags: blocking2.20?
Whiteboard: [blocker will fix] → [blocker will fix] [wanted for 2.20]
Flags: blocking2.20-
(Assignee)

Comment 9

13 years ago
Fixed by bug 288663.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.