Insert Character window doesn't close after open and close two Composer

RESOLVED WORKSFORME

Status

SeaMonkey
Composer
--
minor
RESOLVED WORKSFORME
14 years ago
6 years ago

People

(Reporter: LIVINE Christin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; fr-FR; rv:1.7.2) Gecko/20040803

Insert character window doesn't close even if Mozilla is closed.
Insert Character window doesn't respond to close button.
It affects Composer and Mail compose.

This report looks like bug 217517.
But in this case, it happens when open and close two Composer or two Mail 
compose.
Antoher problem, after close one of Composer (or Mail compose), insert 
character window doesn't work with the last Composer (or Mail compose).


Reproducible: Always
Steps to Reproduce:
1. Launch the Browser.
2. From the browser, launch the Composer.
3. From the Composer, launch another Composer.
4. Launch Insert/Characters and symbols...
5. The Insert/Characters window appears.
6. Close one of Composer windows.
7. Close the last composer window.
8. Close the browser.
9. The Insert character window is still active.
Actual Results:  
You can't close the Insert Character window.

Expected Results:  
The Insert Character window should close.
(Reporter)

Comment 1

14 years ago
*** Bug 257186 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/

Comment 3

13 years ago
Livine, thank you for your clear steps to reproduce. I investigated the issue
and I believe the behavior you noticed is the expected behavior for this kind of
modeless window. Making the "Insert Character" dependent on its opener is not
necessarily flexible for the user opening 2 instances of Composer.

There are similar situations in the navigator. Let's say I have a main window,
let's call it first_navigator_window. I can open the javascript console from
that first_navigator_window. Then I open a brand new window - let's call it
second_navigator_window. The javascritp console will get the errors+messages
when I surf from the second_navigator_window and from the
first_navigator_window. I can close both navigator window and the javascript
console will still remained opened.

Comment 4

12 years ago
*** Bug 312544 has been marked as a duplicate of this bug. ***

Comment 5

10 years ago
SeaMonkey 1.1.9 and 2.0apre - It is work fine

Livine, do you still have this problem with a current builds?

Comment 6

10 years ago
Now, with latest 2.0a1pre rv:1.9pre build 2008040802 under XP Pro SP2, I get the expected results.

Comment 7

10 years ago
Oops... I tested this again and if you try to close the "Insert Character" window with the close button (at the bottom of the window), then it will NOT close... but with the upper left window command system (the X, usually a white X inside a red button if default theme is used), then that "Insert Character window" is closable.

lenochod, can you verify this?

Comment 8

10 years ago
(In reply to comment #7)
> Oops... I tested this again and if you try to close the "Insert Character"
> window with the close button (at the bottom of the window), then it will NOT
> close... but with the upper left window command system (the X, usually a white
> X inside a red button if default theme is used), then that "Insert Character
> window" is closable.

Build identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008040802 SeaMonkey/2.0a1pre
SeaMonkey 1.1.9 Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.13) Gecko/20080313 SeaMonkey/1.1.9

Yes, window isn't close with button "Close", but it is close with X.

Updated

10 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

10 years ago
Duplicate of this bug: 217517
Assignee: composer → nobody
QA Contact: composer
(Reporter)

Comment 10

9 years ago
Tested with with seamonkey 1.1.14 French on windows 2000 French and Windows Vista French.

I add precision for the last step :
You can't close the Insert Character window WHEN CLICKING BUTTON CLOSE, but you can close with X.

1. Launch the Browser.
2. From the browser, launch the Composer.
3. From the Composer, launch another Composer.
4. Launch Insert/Characters and symbols...
5. The Insert/Characters window appears.
6. Close one of Composer windows.
7. Close the last composer window.
8. Close the browser.
9. The Insert character window is still active.
Actual Results:  
You can't close the Insert Character window WHEN CLICKING BUTTON CLOSE, but you can close with X.

Comment 11

8 years ago
Same on Linux with 2.0.1pre.
Severity: normal → minor
OS: Windows 2000 → All

Comment 12

6 years ago
WFM on current trunk, insert character windows now closes with last Composer window
User agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0 SeaMonkey/2.13a1
Build identifier: 20120712003002
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.