tools and help menu don't work after going into full screen mode and customizing menus

RESOLVED FIXED

Status

()

Firefox
Toolbars and Customization
RESOLVED FIXED
13 years ago
11 years ago

People

(Reporter: Max, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2

If you go into fullscreen mode, right-click the toolbar at the top, choose
'customize', scroll down a bit in the customize window that appears, hit 'done',
then press f11 again to get out of fullscreen mode, the tools and help menus
don't work.

Reproducible: Always
Steps to Reproduce:
1. click on f11
2. right-click on the menubar at the top of the screen
3. choose 'customize'
4. scroll down a bit with the scrollbar that appears.
5. hit 'done'.
6. press f11 again to get out of full screen mode.
7. try clicking on 'tools' or 'help'

Actual Results:  
Every time: clicking on 'tools' or 'help', their menu does not appear.
except... just now I tried and only 'help' didn't work.

Expected Results:  
The tools and help menus should have been shown.
(Reporter)

Comment 1

13 years ago
Created attachment 157202 [details]
'tools' clicked on but no menu appears

Comment 2

13 years ago
(In reply to comment #1)
> Created an attachment (id=157202)
> 'tools' clicked on but no menu appears

So how are you getting the right click to even work!  I don't even have a right 
click on the full screen toolbar!  Nothing happens when I right click it.  This 
is v1.0PR.
-Clint

(Reporter)

Comment 3

13 years ago
Hello,

This bug has now basically been fixed because it's no longer possible to
right-click in the toolbar in fullscreen mode.

Thanks!
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Comment 4

13 years ago
Hello.  I don't call that "fixed" by removing a feature!  ;-)  BTW, you CAN 
right click the toolbar in FS mode on FF .9.3....as long as you don't have a 
full screen extension installed.

Which brings up another bug: what the hell is deal with no taskbar in Full 
Screen View!  How the hell are you supposed to access your other open apps & 
webpages?  You have move your hand over to the keyboard and hit the Windows 
key, which of course also pops up the Start menu!  For the life of me, I cannot 
comprehend why FF would leave out such a USEFUL and NEEDED IE feature.
-Clint
(Reporter)

Comment 5

13 years ago
You can access your other open windows by using Alt+Tab or leaving full-screen
mode. If the taskbar is there, then it's not completely full-screen mode - but
this would be for another bug anyway.

Comment 6

13 years ago
(In reply to comment #5)
> You can access your other open windows by using Alt+Tab or leaving full-screen
> mode. If the taskbar is there, then it's not completely full-screen mode - but
> this would be for another bug anyway.

Hello, that's not what I mean.  In IE, all you have to do in full screen view 
is simply hover your cursor at the bottom and the taskbar shows.  One should 
not have to, and it's a pain, to have hit keys on the keyboard or leave full 
screen view to access other apps; instead of the simple and quick IE method.

I can't believe the "geniuses" that designed FF felt the need that no one needs 
access to the Taskbar!! I found only one extension so far that gives you the 
full screen view WITH taskbar autohide/hide like IE, but incredibly this is 
another "genius" that left something CRITICAL out; and that is the icons: "-" 
(minimize), [restore icons], and "X" icons are MISSING from the toolbar in full 
screen view! The only way in it to close a full screen view is making the 
taskbar show, then right clicking the window, then "close"; or clicking 
the "Full screen" icon again, then clicking the "X" at upper right. This is yet 
another reason why FF will never overtake IE--the omission of NEEDED CRITICAL 
features (or bugs).

I've give my left n*t for full screen in FF to be like IE.
-Clint

Updated

11 years ago
QA Contact: bugzilla → toolbars
You need to log in before you can comment on or make changes to this bug.