Suggested language changes for chatzilla.properties in en-US locale

RESOLVED FIXED

Status

Other Applications
ChatZilla
--
trivial
RESOLVED FIXED
14 years ago
12 years ago

People

(Reporter: John J Foerch, Assigned: Robert Ginda)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [cz-0.9.69])

Attachments

(3 obsolete attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040616
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040616

An individual who was writing a Russian language locale file said that some of
the strings in the en-US locale are poorly worded.  I went through the file and
corrected some spelling, grammar and techisms, and changed phrasing in a few
places.  Attached is a diff of the changes I made.

Reproducible: Always
Steps to Reproduce:
(Reporter)

Comment 1

14 years ago
Created attachment 157230 [details] [diff] [review]
Corrected some spelling and gammar.  Reworded some techisms.

Comment 2

14 years ago
We have received several questions from translators about the following string
in chatzilla.properties as well:

1030 pref.usermode.help              = Your usermode determins how the IRC
server treats you (it is a list of letters preceeded by "+") - for example, you
can get the server to send to message about "behind the scenes"-like things but
setting a different usermode. The most common option, "i", makes you not show up
as a member of a channel unless the user making the query is already in the
channel (it stands for "invisible").
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 3

14 years ago
Philip, read the suggested replacement for that string in the patch I submitted
and tell me if the new version is clear.  That one was actually the initial
reason for submitting this patch.

Comment 4

14 years ago
Comment on attachment 157230 [details] [diff] [review]
Corrected some spelling and gammar.  Reworded some techisms.

I think you did a great job with these changes - they really improve the
ChatZilla messages. Just a few comments on the changes:

>-pref.activityFlashDelay.help    = When a tab that has already had activity on it gets more activity, the tab is flashed to indicate this. This preference is the length of the flash, 0 disables it.
>+pref.activityFlashDelay.help    = When a tab that has had activity gets more activity, the tab is flashed. This preference is the length of the flash: 0 disables it.

The length of the flash in what units? Seconds? Milliseconds?

>-pref.dcc.listenPorts.help       = List of ports that other user can connect to remotely. Each item may be a single port number, or a range specified as "lower-upper". Leave empty to use a random, OS-picked port always. Each time you offer a DCC connection to someone, the next port listed is picked.
>+pref.dcc.listenPorts.help       = List of ports that other user can connect to remotely. Each item may be a single port number, or a range specified as "lower-upper". Leave empty to use a random, OS-picked port. Each time you offer a DCC connection to someone, the next port listed is picked.

"other users"?

>-pref.initialURLs.help           = A list of IRC URLs that Chatzilla should connect to (load) when starting. These will not be loaded if Chatzilla is started because of a URL that goes somewhere (e.g. irc://moznet/).
>+pref.initialURLs.help           = A list of IRC URLs to which ChatZilla should connect when starting. These will not be processed if Chatzilla was started because of an irc:// hyperlink.

Maybe "by clicking on an irc:// hyperlink"?

>-pref.logFileName.help           = This is the file which Chatzilla will log this view to. Generally, if the view is currently open and logging, changing this option won't take effect until it next starts logging.
>+pref.logFileName.help           = This is the file which Chatzilla will log this view to. If the view is currently open and logging, changing this option won't take effect until it next starts logging.

How about:
"The log file used for this view. If the view is currently open and logging,
changing this option won't take effect until the next time it starts logging."

>-pref.munger.rheet.help          = Makes Chatzilla turn "rheet" into a link (a very Mozilla.org-centric feature).
>+pref.munger.rheet.help          = Makes Chatzilla hyperlink "rheet": a very Mozilla.org-centric feature.

Dunno about the colon here.

>-pref.newTabLimit.help           = Sets the number of views (such as query views) that may be created automatically by Chatzilla. Once the limit is reached, private messages will show up on the current view instead. Set this to 0 for unlimited, or 1 to disallow all auto-created views.
>+pref.newTabLimit.help           = Sets the number of views (such as query views) that may be created automatically by Chatzilla. Once the limit is reached, private messages will show up on the current view instead. Set this to 0 for unlimited; 1 to disallow auto-creation of views.

I prefer the original text here.

Other errors I found in chatzilla.properties which were not fixed in your
patch:
- cmd.motif.help has "See the the ChatZilla homepage".
- cmd.header.help should have "visibility" instead of "visiblility".
- cmd.leave.help - "the the tab will not be deleted".
- cmd.ping.help - "Specifiying".
- cmd.user-motif.help - "the the ChatZilla homepage".
- msg.cancelling - "Cancelling" should be "Canceling".
- msg.prefs.err.save - "occured" should be "occurred".
- pref.connectTries.help - "attemps" should be "attempts".
- pref.debugMode.help - "deubgging" should be "debugging".
- pref.log.help - "overriden" should be "overridden".
- pref.sound.surpressActive.label - "supress" should be "suppress".
(Reporter)

Comment 5

14 years ago
Created attachment 157587 [details] [diff] [review]
Updated corrections for locale/en-US/chatzilla.properties
(Reporter)

Updated

14 years ago
Attachment #157230 - Attachment is obsolete: true
(Reporter)

Comment 6

14 years ago
Excellent.  I updated the patched.  Some notes:

"A list of IRC URLs to which ChatZilla should connect when starting. These will
not be processed if Chatzilla was started by clicking on a hyperlink to an irc
host."

As it turns out, clicking a hyperlink of simply "irc://" Will cause ChatZilla to
process the initialURLs list.  So I reworded it to reflect that truth.



>+pref.munger.rheet.help          = Makes Chatzilla hyperlink "rheet": a very
Mozilla.org-centric feature.

Here my edit was to eliminate the period following a parenthese.  The colon is
grammatically correct, but now I am thinking: this line is supposed to be
humorous, so maybe it should be an exclamation instead of a simple statement. 
How about "Makes Chatzilla hyperlink "rheet": a Mozilla-org centric feature!"



"Sets the number of views (such as query views) that may be created
automatically by Chatzilla. Once the limit is reached, private messages will
show up on the current view instead. Set this to 0 for unlimited; 1 to disallow
auto-creation of views."

New patch gets rid of the semicolon but keeps the phrasing "to disallow
auto-creation of views."  The original "to disallow all auto-created views"
implies that the views were already created when they were disallowed, which is
not true.


The other things you mentioned are in the new patch exactly, along with a few
other ones that I noticed along the way.

The misspelled word "cancelling" appears in a variable name as well as in a
string.  I'll submit that as a separate bug because that will presumably require
changes to at least one other file.

Comment 7

14 years ago
All the changes look good to me. We should get this reviewed and checked in by
one of the ChatZilla maintainers. I have a few more suggested changes, although
they are pretty minor.

1) "cmd.ping.help   = Ping takes its name from the technique of measuring
distance with sonar.  In IRC, it is used to measure the time it takes to send a
message to someone, and receive a response.  Specify a channel to ping everyone
in that channel.  Some IRC clients will display ping requests to the user. 
ChatZilla does not."

I think we can leave out the first sentence here, as I would assume most IRC
users are familiar with the word 'ping' in this context.

Maybe rewrite as:
"The ping command is used to measure the time it takes to send a message to a
user and receive a response. If this command is given a channel name as a
parameter, it will attempt to ping all users in the channel. Some IRC clients
display ping requests to the user, however ChatZilla does not."

2) "pref.debugMode.help             = This preference is for debugging Chatzilla
and can generate a lot of debug output (usually to the console). It is a list of
letters, signifying what you want debug messages about. "c" for context menus
(dumps data when opening a context menu), "d" for dispatch (dumps data when
dispatching commands), and "t" for trace/hook (dumps data about hooks and the
event queue processing) debugging."

I think this may be rewritten as follows:
"This preference is used by developers to debug ChatZilla, and can generate a
lot of output to the console. It is a list of letters, signifying the type of
debug information ChatZilla should display. The valid letters are: "c" (displays
data when opening context menus), "d" (displays data when dispatching commands),
and "t" (displays data about hooks and event queue processing)."
(Reporter)

Comment 8

14 years ago
About the ping helptext, I threw that in for some good ol' user friendliness. It
was actually a long time after I was first introduced to irc that I found out
the origin of the word ping.  And I think that even people who already know
those little factoids still get a little joy from reading them again.  So my
instinct would be that this is a good place for a little digression from
computerese to say something about the etymology of a funny word like ping.

About the debug characters.  I'm not really satisfied with the help text as it
stands either. Not because it's not clear, but because it doesn't tell the whole
story. To make debugging work, there's actually a preference in mozilla that
also has to be set.  Simply setting chatzilla's debug pref doesn't do anything
if debugging is not enabled in the browser.  So if we want to rewrite the debug
help text in this patch, we need to rewrite it to tell the whole truth.

What did you think about the rheet text that I suggested in my last post?



Comment 9

14 years ago
(In reply to comment #8)
> About the debug characters.  I'm not really satisfied with the help text as it
> stands either. Not because it's not clear, but because it doesn't tell the whole
> story. To make debugging work, there's actually a preference in mozilla that
> also has to be set.  Simply setting chatzilla's debug pref doesn't do anything
> if debugging is not enabled in the browser.  So if we want to rewrite the debug
> help text in this patch, we need to rewrite it to tell the whole truth.

This is up to you if you want to rewrite all of this. I think we are ok to go
ahead with the current changes which are a great improvement over the old ones.

> What did you think about the rheet text that I suggested in my last post?

I think the "rheet" feature of ChatZilla will still be very confusing to
translators, and I can't think of a good way to describe what exactly it does.

Updated

14 years ago
Attachment #157587 - Flags: review?(silver)
Product: Core → Other Applications

Comment 10

13 years ago
Created attachment 200930 [details] [diff] [review]
[checked in] New patch against current cvs

New patch using current CVS. Glad all the 'ommits' were taken out already :-)
Attachment #157587 - Attachment is obsolete: true
Attachment #200930 - Flags: review?(silver)
Attachment #157587 - Flags: review?(silver)

Comment 11

13 years ago
Comment on attachment 200930 [details] [diff] [review]
[checked in] New patch against current cvs

>+pref.username.help              = our username is used to construct your "host mask", which is a string representing you. It includes your connection's host name and this username. It is sometimes used for setting auto-op, bans, and other things specific to one person.

Missing "Y" at the start there, I think!

r=silver with that fixed.
Attachment #200930 - Flags: review?(silver) → review+

Updated

13 years ago
Attachment #200930 - Attachment description: New patch against current cvs → [checked in] New patch against current cvs
Attachment #200930 - Attachment is obsolete: true

Comment 12

13 years ago
Checked in --> FIXED.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Updated

12 years ago
Whiteboard: [cz-0.9.69]
You need to log in before you can comment on or make changes to this bug.