XP SP2 Breaks Mozilla (windows compatibility mode problem)



14 years ago
13 years ago


(Reporter: jeff givens, Unassigned)


Windows XP
Bug Flags:
blocking-aviary1.0 -

Firefox Tracking Flags

(Not tracked)




14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.2) Gecko/20040803
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.2) Gecko/20040803

After sp2 install any launching of mozilla results in nothing happening. No
process, nothing. Re-installing appears to go well but still nothing when
launching the program. Uninstalled and re-installed to no avail.

I don't know if this is related to bug 233765 or not. This is not an athlon (p4)
and there is no crach - just no evidence of anything happening.

I have not tried removing sp2.

Reproducible: Always
Steps to Reproduce:
1.install mozilla
2.install sp2

Comment 1

14 years ago
Problem is related to windows compatibility mode. I run in win2k mode, due to
bug 225894. Now Moz won't run but in native xp mode, which of course brings the
falsh bug back into play.
Summary: XP SP2 Breaks Mozilla → XP SP2 Breaks Mozilla (windows compatibility mode problem)

Comment 2

14 years ago
Playing around in windows compatibility manager I have found that the setting
causing the problem is the "VirtualRegistry" setting. Selecting win2k compat
then unchecking this setting, save and install, causes Moz to once again run.

Comment 3

14 years ago
how do you get to the "windows compatibility manager" and make these settings?


14 years ago
Flags: blocking-aviary1.0?

Comment 4

14 years ago
(In reply to comment #3)
> how do you get to the "windows compatibility manager" and make these settings?

WCM is a full blown manager of compatability settings. In XP you can right click
a file and choose compatibility but this only gives you some blanket fixes, the
WCM lets you be much more selective on the fixes applied.

See http://bugzilla.mozilla.org/show_bug.cgi?id=225894#c32 for explicit details.
Follow the instructions but in this case (not caring about flash) only uncheck
the  'virtualregistry' checkbox.

Comment 5

14 years ago
I'm unable to reproduce this problem on two different XP SP2 machines, one a P4
and the other an AMD64. I've tested with admin and limited accounts and cannot
trigger a failure.

per bsmedberg

if this is ?1.0, so why not confirmed ?
Flags: blocking-aviary1.0? → blocking-aviary1.0-

Comment 7

14 years ago
(In reply to comment #5)
> I'm unable to reproduce this problem on two different XP SP2 machines, one a P4

I've just checked again (1.8a3) and if I mark mozilla.exe to run in win 2k
compatibility mode, it dies. It does nothing at all visible when executed. I am
on xp sp2 (of course) with all current updates. P4 3.0e.

Maybe related to the install sequence? I did not try a setup where win xp sp2
was in place before a mozilla install was made.

Product: Browser → Seamonkey
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
This bug has been automatically resolved after a period of inactivity (see above
comment). If anyone thinks this is incorrect, they should feel free to reopen it.
Last Resolved: 13 years ago
Resolution: --- → EXPIRED
You need to log in before you can comment on or make changes to this bug.