Firefox does not start when clicking a http link

VERIFIED DUPLICATE of bug 247644

Status

defect
--
blocker
VERIFIED DUPLICATE of bug 247644
15 years ago
13 years ago

People

(Reporter: whimboo, Assigned: mscott)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

version 0.7+ (20040827)

When you receive a message which contains a link to a webpage, Thunderbird
doesn't start Firefox or another application (not yet tested) which is set as
external protocol handler. There is no error within the js console. Other
application with clickable http addresses are able to start Firefox. So it seems
to be a bug within Thunderbird.

This bug should block the next 0.8 release of Thunderbird, so marking as blocker.

Comment 1

15 years ago
I believe this might be a duplicate of Bug 221909.

Reporter (Henrik): Please check Bug 221909 and mark this bug as a duplicate if
you agree that it is.
Mmh I tested the way described in bug 221909. Nothing happens. Instead when I
set Mozilla as default browser TB opens Mozilla and displays the web page. 

This have to be a problem with FF and TB? It don't mark this bug as dupe
actually. Before i do that I will get more informations from the other bug.

Comment 3

15 years ago
I've been experiencing the problem as well. I have tried mentioning it on
numerous MozillaZine threads and Bugzilla bugs, but nothing has been done.
Please don't mark this as a dupe to a "fixed" bug, I know it's happening and
I've seen other comments by users that are experiencing it.

I have FireFox 0.9.3 and Thunderbird 0.7.3 on WindowsXP SP1.

If I set IE as my default browser, clicking on links works fine. The only time I
experience the problem is when FireFox is set as default.
(Assignee)

Comment 4

15 years ago
I really think this is a Firefox issue and not a Thunderbird issue since link
clicks work if other browsers besides firefox are the default.
(In reply to comment #4)
> I really think this is a Firefox issue and not a Thunderbird issue since link
> clicks work if other browsers besides firefox are the default.

Scott, starting FF works perfectly from other programs but not TB. How could i
get closer to this issue? Could I start a log or how could i see if TB or FF fails?

Comment 6

15 years ago
 Apologies in advance for what may be bug-spam.

 There are at least four bugs which all report the exact same problem as Bug
221909. They are: Bug 247644, Bug 24881, Bug 251089 and Bug 257228 (this bug).

Comment 7

15 years ago
Excuse me, that should be Bug 248811 (not 24881).
Thank you jwq for the buglist. I duped every bug to bug 247644 which contains
the helpful information.

*** This bug has been marked as a duplicate of 247644 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
I have the same problem. Since I installed Firefox 2.0 I can click on any link in any mail, I can click on Help - Mozilla Thunderbird Help - but only the old version has started. I have deinstalled the old version (1.5x), and there is no conection to my new Firefox. I have to copy the linkadress and open it manual, but this is not as comfortable as usual. I think it's a problem between this programms, but I can't find a solution. My Thunderbird has all updates. I have only "Talkback" and "Quicktext"-Extension (German version).
With kind regards
Kerstin
(In reply to comment #9)
> I have the same problem. Since I installed Firefox 2.0 I can click on any link
> in any mail, I can click on Help - Mozilla Thunderbird Help - but only the old
> version has started. I have deinstalled the old version (1.5x), and there is no
> conection to my new Firefox. I have to copy the linkadress and open it manual,

Seems that Fx2 hasn't registered as the default browser onto your system. Do that by opening the main tab inside options and hit "Check Now". Fx2 should register itself as the default browser. Afterwards clicking any link inside Thunderbird should open the desired page in Fx2.
(In reply to comment #10)
> 
> Seems that Fx2 hasn't registered as the default browser onto your system. Do
> that by opening the main tab inside options and hit "Check Now". Fx2 should
> register itself as the default browser. Afterwards clicking any link inside
> Thunderbird should open the desired page in Fx2.
> 

Great, that was the right hint.. ;.) Thanks. 
If there is anyone else with the german version: 
in der deutschen Version unter Extras -- Einstellungen -- Allgemein -- der unterste Punkt Systemeinstellungen dort auf "Jetzt überprüfen" klicken.
Regards,
Kerstin.
You need to log in before you can comment on or make changes to this bug.