When browsing the back navigation does not take you back to the link location on the previous page.

RESOLVED DUPLICATE of bug 216376

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 216376
14 years ago
12 years ago

People

(Reporter: wes sweet, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3

When browsing the back navigation does not take you back to the link location on
the previous page. 

Run a google query. Scroll down to one of the bottom links and click. When you
click back it takes you to the top of the google page - you have to scroll down
to continue where you left off.

Reproducible: Sometimes
Steps to Reproduce:
1. Scroll down on a web page
2. Click a link to another page.
3. Click the back button.
Actual Results:  
Problem - you end up at the top of the previous page and you have to scroll back
down to continue where you left off.

Expected Results:  
I expect it to go back to the spot on the page where I left.

Comment 1

14 years ago
WFM Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2) Gecko/20040826
Firefox/0.9.1+
Summary: When browsing the back navigation does not take you back to the link location on the previous page. → When browsing the back navigation does not take you back to the link location on the previous page.
WFM

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3
This may be a dupe of bug 215405. Reporter, can you specify a specific page that
this happens on? What are you cache settings?
(Reporter)

Comment 4

14 years ago
Same behavior as listed in 215405. My cache is set to 50000 KB. This happens on 
most pages, but not all. In my MSN home page it works fine and I go back to 
link position. On my Yahoo page and google it does not. Can you recreate?
> Can you recreate?

No I can't, and it does not seem like anybody else can either.

Since it's happening at Google, it's not bug 215405. Google does not put the
cache-control: no-store meta tags in its search results as far as I know.

Could you try to reproduce this on another computer or with a new profile/new
install?

Comment 6

13 years ago
This bug may be more related to bug 216376 than bug 215405, due to Firefox as
the user-agent.

Comment 7

12 years ago
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7)
> Gecko/20040803 Firefox/0.9.3
> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7)
> Gecko/20040803 Firefox/0.9.3
> 
> When browsing the back navigation does not take you back to the link location
> on
> the previous page. 
> 
> Run a google query. Scroll down to one of the bottom links and click. When you
> click back it takes you to the top of the google page - you have to scroll down
> to continue where you left off.
> 
> Reproducible: Sometimes
> Steps to Reproduce:
> 1. Scroll down on a web page
> 2. Click a link to another page.
> 3. Click the back button.
> Actual Results:  
> Problem - you end up at the top of the previous page and you have to scroll
> back
> down to continue where you left off.
> 
> Expected Results:  
> I expect it to go back to the spot on the page where I left.
> 

(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7)
> Gecko/20040803 Firefox/0.9.3
> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7)
> Gecko/20040803 Firefox/0.9.3
> 
> When browsing the back navigation does not take you back to the link location
> on
> the previous page. 
> 
> Run a google query. Scroll down to one of the bottom links and click. When you
> click back it takes you to the top of the google page - you have to scroll down
> to continue where you left off.
> 
> Reproducible: Sometimes
> Steps to Reproduce:
> 1. Scroll down on a web page
> 2. Click a link to another page.
> 3. Click the back button.
> Actual Results:  
> Problem - you end up at the top of the previous page and you have to scroll
> back
> down to continue where you left off.
> 
> Expected Results:  
> I expect it to go back to the spot on the page where I left.
> 

(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7)
> Gecko/20040803 Firefox/0.9.3
> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7)
> Gecko/20040803 Firefox/0.9.3
> 
> When browsing the back navigation does not take you back to the link location
> on
> the previous page. 
> 
> Run a google query. Scroll down to one of the bottom links and click. When you
> click back it takes you to the top of the google page - you have to scroll down
> to continue where you left off.
> 
> Reproducible: Sometimes
> Steps to Reproduce:
> 1. Scroll down on a web page
> 2. Click a link to another page.
> 3. Click the back button.
> Actual Results:  
> Problem - you end up at the top of the previous page and you have to scroll
> back
> down to continue where you left off.
> 
> Expected Results:  
> I expect it to go back to the spot on the page where I left.
> 

(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7)
> Gecko/20040803 Firefox/0.9.3
> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7)
> Gecko/20040803 Firefox/0.9.3
> 
> When browsing the back navigation does not take you back to the link location
> on
> the previous page. 
> 
> Run a google query. Scroll down to one of the bottom links and click. When you
> click back it takes you to the top of the google page - you have to scroll down
> to continue where you left off.
> 
> Reproducible: Sometimes
> Steps to Reproduce:
> 1. Scroll down on a web page
> 2. Click a link to another page.
> 3. Click the back button.
> Actual Results:  
> Problem - you end up at the top of the previous page and you have to scroll
> back
> down to continue where you left off.
> 
> Expected Results:  
> I expect it to go back to the spot on the page where I left.
> 

Comment 8

12 years ago
Dupe of bug 216376 which is in contrast to bug 215405 unrelated to cache-control.

*** This bug has been marked as a duplicate of 216376 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.