Firefox deletes history.dat when it's more than 4.8M

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
RESOLVED WORKSFORME
13 years ago
9 years ago

People

(Reporter: Xanthor Sccas, Unassigned)

Tracking

1.5.0.x Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CLOSEME 07/14)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040207 Firefox/0.8
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3

When I launch FireFox, if my history.dat is more than about 4.8M, Firefox
deletes it and creates a new one, empty...

Reproducible: Always
Steps to Reproduce:
1. Browse a lot until your history.dat riches 4.8M or more.
2. Close Firefox
3. Reopen it
Actual Results:  
history.dat is replaced by a new empty one

Expected Results:  
Keep my history...

My profil is on a ext3 filesystem...


Maybe it occures also on Mozilla, but I haven't really tested..

Comment 1

13 years ago
WFM Mozilla 1.7-1.8a3+ on WinNT4. history.dat is ~5.8 MB. 
dupe of 242207 ?

*** This bug has been marked as a duplicate of 242207 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Comment 4

13 years ago
It is not a duplicate of bug 242207. That bug is about frequent random purges.
This is about clearing history when history.dat is too big, on Linux, under
Firefox, which makes comment 1 irrelevant.

This needs to be either WFM'ed or confirmed (or duped against another bug).
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Assignee: bross2 → nobody
QA Contact: mozilla → history
Reporter, do you still see this problem with the latest Firefox 2? If not, can you please close this bug as WORKSFORME. Thanks!
Whiteboard: CLOSEME 07/14
Version: unspecified → 1.5.0.x Branch
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.5pre) Gecko/20070705 BonEcho/2.0.0.5pre ID:2007070504

WFM and no response from reporter re: comment 5 -->WORKSFORME.
Reporter, if you still see this problem with the latest release of Firefox 2, please reopen this bug. Thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago10 years ago
Resolution: --- → WORKSFORME

Updated

9 years ago
Component: History → Bookmarks & History
QA Contact: history → bookmarks
You need to log in before you can comment on or make changes to this bug.