The close tab button gives visual feedback but the tab does not close

RESOLVED FIXED

Status

()

Firefox
Tabbed Browser
--
trivial
RESOLVED FIXED
14 years ago
12 years ago

People

(Reporter: Christoph Studer, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20040829 Firefox/0.9.1+ StumbleUpon/1.995
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20040829 Firefox/0.9.1+ StumbleUpon/1.995

Missing the close tab button by a few pixels verically does show visual feedback
(mouse-over, mouse-down) but does not close the tab.

You have to move the mouse cursor closer to the red icon of the button and click
to really close the tab.

I know this is ultra-fussy but I stumble across this bug quite often.

Reproducible: Always
Steps to Reproduce:
1. Be sure the tab bar is shown by opening a few tabs
2. Approach the red close tab button from the top or bottom until visual
mouse-over feedback is given. Make sure you really stop moving the mouse once
the mouse over state is reached. Do not enter the red square.
3. Click.
4. If the tab closes, open a new one and try again (step #2) but try to stay as
far away as possible from the red square. It's only a 1-2px area where tabs do
not close.
Actual Results:  
Visual mouse-over and mouse-down feedback for the close tab button is given, but
the tab does not close.

Expected Results:  
Either
  - Do not provide visual feedback (change) and do not close the tab (status quo)
or
  - Provide visual feedback (status quo) and close the tab (change)
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.3) Gecko/20040829
Firefox/0.9.1+

WFM
WFM
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3

Comment 3

14 years ago
I can reproduce this.  From trying it multiple times, it looks like there is a 2
pixel "border" on the bottom where I can get the onmouseover effect, but
pressing the button won't actually close the tab.  It seems to be 1 pixel on
top, and left and right work correctly.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

14 years ago
see bug 245806 for further info the close button

Comment 5

14 years ago
Confirmed. I came to bugzilla just now to file this bug. 

Warner is correct; there exists a 2 pixel area around the close tab button that,
when clicked in this area, the button will visually "click" but the tab will not
close. If you move in two pixels and click again, it works.

Comment 6

14 years ago
Whoops, I didn't include build/OS information. I apologize. 

Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914 Firefox/0.10
Slackware Linux 10

Comment 7

14 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10
win XP

The fake 2px border is on top and bottom of the close button

It seems to be a mutiplatform bug
Someone with mac to confirm?
(Reporter)

Comment 8

14 years ago
(In reply to comment #7)
> It seems to be a mutiplatform bug
> Someone with mac to confirm?

Cannot reproduce with Mac version. There's less space between the close button
and the toolbar/main content area. Also, there's no visual mouse-over feedback.

It seems that, whenever the button shows mouse-down feedback, a tab closes.

--> WFM on Mac

Comment 9

14 years ago
Created attachment 161353 [details] [diff] [review]
patch: fixes problem with clickable area of tab close button

The problem was indeed the spacing around the button.  The amount of top
padding changed on-click, essentially making a "phantom" spot on the top of the
button where clicking would give visual feedback but wouldn't actually do
anything.  I'm sure the intent was to make the padding "static" and remove the
usual one-pixel click drop effect on toolbar buttons, but it resulted in this
side effect.  This same problem afflicted the sidebar close button as it uses
the same padding values as the plain tab close button.	This patch should fix
both.  I can't vouch for XP (Luna), but Windows Classic works as expected now.

Comment 10

12 years ago
This appears to have been fixed for some time. Marking resolved. 
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.