If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Mozilla environment variables should be documented somewhere

RESOLVED WONTFIX

Status

Developer Documentation
Mozilla Platform
P4
normal
RESOLVED WONTFIX
13 years ago
2 years ago

People

(Reporter: 8Dcgou9BB9Wnzpj, Assigned: sheppy)

Tracking

Details

(Whiteboard: u=mozdev p=0 c=Platform)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.7) Gecko/20040617
Build Identifier: Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.7) Gecko/20040617

mozilla environment variables are not documented in help

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Comment 1

13 years ago
what environment variables?

Comment 2

13 years ago
Here's some to start:

MOZ_NO_REMOTE - prevents two mozilla instances from talking to each other
MOZ_PLUGIN_PATH - where mozilla finds plugin

Linux only
MOZILLA_FIVE_HOME

OS/2 only
MOZILLA_HOME - where Mozilla stores stuff
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: OS/2 → All
Hardware: PC → All
Summary: mozilla environment variables are not documented in help → Mozilla environment variables should be documented somewhere

Comment 3

13 years ago
Guilt guilt for me. If people bang their suggestions in here I'll
make sure they reach at least paper eventually.
Product: Browser → Seamonkey

Comment 4

13 years ago
This shouldn't be in Mozilla Help, since that just covers the ui. Perhaps it
might be something for the documentation on mozilla.org?

Comment 5

8 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED

Comment 6

7 years ago
As Stefan says, this is more suited for technical documentation (MDC), moving to relevant product/component.
Assignee: neil → nobody
Component: Help → Documentation Requests
Product: SeaMonkey → Mozilla Developer Center
QA Contact: danielwang → doc-request
Version: Trunk → unspecified
(Assignee)

Comment 7

7 years ago
I agree; this needs to be documented somewhere on MDC. Is there a place in the code to look them up?

Comment 8

7 years ago
Searching for 'getenv' and 'GetEnv' should give a majority of them, if not all.  

'getenv': http://mxr.mozilla.org/mozilla-central/ident?i=getenv

'GetEnv': http://mxr.mozilla.org/mozilla-central/ident?i=GetEnv

Not sure why, but the mixed-case version returns some non-matches. 

In some cases the call doesn't use a string literal, so the actual names of the variables being retrieved will be set elsewhere and further digging will be required.

I'm not clear if any of them won't actually be used by an application and only appear as part of library code that's not actually reachable (eg, SQLite references a TMPDIR, but it may not be used when SQLite is used via an application?).

Some of the variables are already documented under MDC: NSS environment variables at https://developer.mozilla.org/en/NSS_reference/NSS_environment_variables
Component: Documentation Requests → Documentation
Product: Mozilla Developer Network → Mozilla Developer Network
Automatically closing all bugs that have not been updated in a while. Please reopen if this is still important to you and has not yet been corrected.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
Reopening for review by Sheppy.
Assignee: nobody → eshepherd
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: INVALID → ---
(Assignee)

Updated

5 years ago
Priority: -- → P4
Component: Documentation → General
Product: Mozilla Developer Network → Developer Documentation
(Assignee)

Updated

5 years ago
Whiteboard: u=mozdev p=0
(Assignee)

Updated

5 years ago
Component: General → Mozilla Platform
Whiteboard: u=mozdev p=0 → u=mozdev p=0 p=Platform
(Assignee)

Updated

5 years ago
Whiteboard: u=mozdev p=0 p=Platform → u=mozdev p=0 c=Platform
This is no longer in scope of MDN.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.