help pages pointing to mozilla.org are almost useless

RESOLVED FIXED in Firefox1.5

Status

Firefox Graveyard
Help Documentation
--
enhancement
RESOLVED FIXED
14 years ago
2 years ago

People

(Reporter: a_geek, Assigned: Jeff Walden (gone starting June 8))

Tracking

unspecified
Firefox1.5

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3

The help pages have copious references to mozilla.org when some details are in
order, eg. for "Troubleshooting". Now, if you want to troubleshoot something,
then you may have some difficulties going online in the first place, so eg. this
link is almost useless to me. Also, there are enough situations where you just
can't go online and want to use eg. Firefox for local file viewing, or operating
web local applications, only. This problem applies to other areas as well, like
the FAQ. Also, the documentation misses a lot of details.

I'd like to see a firefox-documentation package that can be installed locally
that contains all there is on Firefox.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.




Workaround: Pause work until access to online documentation becomes available
(again, or at a different place).
Status: UNCONFIRMED → NEW
Ever confirmed: true
The troubleshooting pages on mozilla.org seem outdated, and seem to apply to
Seamonkey and not firefox. It would probably be a good idea to completely remove
the link to that page in Fx help. BTW, I don't see any links or references to
mozilla.org but the Release Notes and Troubleshooting. Unless there's a copy of
the release notes in HTML formal already installed locally onto firefox, I see
no reason to not just use the link to moz.org.
(Reporter)

Comment 2

14 years ago
The main reason why I'd like to see complete local documentation is that I need
it in situations where I can't go to any online resource, or where I'd have to
wait several hours to days before I can go online and research any problems. So,
even the most current online documentation doesn't help me a bit when I can't
get it. I don't know how many other people are affected by this, however.

With local documentation, the chance for stumbling over this issue would be reduced.

Comment 3

14 years ago
You might want to ask bart, since I think he's in control of those pages. He's
probably the person to propose such a change to, considering it would need a lot
of updating.
(Reporter)

Comment 4

14 years ago
Maybe the help pages could be packaged separately and installed via the
extensions mechanism. Wouldn't help on the first round, however :/
(Assignee)

Comment 5

14 years ago
Troubleshooting has been removed through bug 263547.  The rest of the links are
generally useful and not evil, although I consider the Netscape link to get
plug-ins to be dubious at best.  I might possibly remove that one sometime
relatively soon.
OS: Linux → All
Hardware: PC → All
Target Milestone: --- → After Firefox 1.0

Comment 6

14 years ago
*** Bug 265701 has been marked as a duplicate of this bug. ***

Comment 7

14 years ago
Jeff, we should either remove (comment out) the whole sentence containing the
link to http://channels.netscape.com/ns/browsers/plugins.jsp, which is terribly
out-of-date, or replace the link by https://update.mozilla.org/plugins/, which
might contain some content in the future (see bug 258955 comment 19).
(Assignee)

Comment 8

13 years ago
The netscape.com link is going away after I get a permanent link (possibly
<https://pfs.mozilla.org/plugins/>, but I need to verify with jst that it's
permanent) that'll go to the plugins page on u.m.o.  The rest will more or less
stay, although there'll be further tweaking for bug 277328.
Status: NEW → ASSIGNED
Target Milestone: Future → Firefox1.1
(Assignee)

Comment 9

13 years ago
I don't see anything else that needs doing here.  The few links remaining in
docs mostly link to addons and plugin stuff and are quite useful, so I think we
can close this.
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.